Advertise on Bikeforums.net



User Tag List

Results 1 to 2 of 2

Thread: Squeaky V's

  1. #1
    The Rabbi seely's Avatar
    Join Date
    Apr 2004
    Posts
    4,962
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Squeaky V's

    I'm having a really odd problem tonight. The rear V's on my commuter I just built are squeaking like crazy... odd thing is I ran these brakes for 2 years with no squeaking. Pads are Koolstop Salmon/Blacks with 3 or 4 hard rides on them, and never squeaked until tonight. I did not adjust the brakes at all, though I have now checked that the pads are hitting even, toed, sanded the pads, sanded the rim, cleaned the rim with metal prep, checked that the boss bolts are tight, etc. I CANNOT figure this one out--especially since its just tonight that it has been an issue. All I did was change the gearing and install a rack basically... very frustrating. I think I might just swap out the V's for a nice set of canti's I have lying around tomorrow.
    commuter turned bike mechanic turned commuter (also a Velocity USA employee, but this is my personal account)

  2. #2
    The Rabbi seely's Avatar
    Join Date
    Apr 2004
    Posts
    4,962
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I should add I swapped out the Koolstop Salmon/Blacks for a pair of Avid cartridge pads that had previously been used on these rims, only to have them squeak just as badly.
    commuter turned bike mechanic turned commuter (also a Velocity USA employee, but this is my personal account)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •