Cycling and bicycle discussion forums. 
   Click here to join our community Log in to access your Control Panel  


Go Back   > >

Bicycle Mechanics Broken bottom bracket? Tacoed wheel? If you're having problems with your bicycle, or just need help fixing a flat, drop in here for the latest on bicycle mechanics & bicycle maintenance.

User Tag List

Reply
 
Thread Tools Search this Thread
Old 08-16-06, 11:03 AM   #1
the beef
100% USDA certified
Thread Starter
 
the beef's Avatar
 
Join Date: Feb 2006
Location: Seattle -> NYC
Bikes: Bianchi XL EV2
Posts: 4,022
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Graar. When your cranks go "click"..

I've got an old Schwinn Super Sport, beautiful condition and all with a Suntour Aero 52-42 crankset. It's just that it'll emit this blunt 'click' noise once every revolution in the same spot, especially if pedaling hard. It's really gotten on my nerves, and to the best of my knowledge the problem developed recently.

Any of you guys have experience or suggestions? I'm not sure if I should check the pedals, the crankset, BB, or what. I don't want to have to replace the bottom bracket/crankset. Anyway, thanks a lot, appreciate all the help.

Last edited by the beef; 08-16-06 at 11:19 AM.
the beef is offline   Reply With Quote
Old 08-16-06, 11:16 AM   #2
Gonzo Bob
cycles per second
 
Gonzo Bob's Avatar
 
Join Date: Oct 2003
Location: Minnesota
Bikes: Vitus Aluminum, DiamondBack Apex, Softride Powerwing 700, "Generic" Ishiwata 022, Trek OCLV 110
Posts: 1,790
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
http://www.slowtwitch.com/mainheadin...nk_noises.html

In my 20 years of experience, it's most often loose chain ring bolts. But it can be other stuff. Also check that the crank is not hitting anything else like the front derailer or chain stay.
Gonzo Bob is offline   Reply With Quote
Old 08-16-06, 11:29 AM   #3
shakeNbake
Mooninite
 
shakeNbake's Avatar
 
Join Date: May 2006
Location: South of Heaven
Bikes: $53 Walmart Special
Posts: 3,187
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Mine did that. It took a full day of trial and error until I found out it was my seat. ARRRGGHH!!
shakeNbake is offline   Reply With Quote
Old 08-16-06, 11:48 AM   #4
mmerner
okay maybe not.
 
mmerner's Avatar
 
Join Date: Jun 2004
Location: waukesha, wi
Bikes: oh a bunch.
Posts: 598
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had dirt on the pedal threads causing the same noise.
__________________
question everything.
mmerner is offline   Reply With Quote
Old 08-16-06, 12:37 PM   #5
the beef
100% USDA certified
Thread Starter
 
the beef's Avatar
 
Join Date: Feb 2006
Location: Seattle -> NYC
Bikes: Bianchi XL EV2
Posts: 4,022
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Ah. Thanks for the great help from everybody. Turns out it was the chainring bolts (great link from Gonzo).

Don't you just hate those mystery clicks and creaks? Anyway, problem solved.
the beef is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 12:30 AM.