Cycling and bicycle discussion forums. 
   Click here to join our community Log in to access your Control Panel  


Go Back   > >

Bicycle Mechanics Broken bottom bracket? Tacoed wheel? If you're having problems with your bicycle, or just need help fixing a flat, drop in here for the latest on bicycle mechanics & bicycle maintenance.

User Tag List

Reply
 
Thread Tools Search this Thread
Old 06-25-07, 07:50 AM   #1
George
Senior Member
Thread Starter
 
George's Avatar
 
Join Date: Jul 2006
Location: Katy Texas
Bikes: Specialized Roubaix
Posts: 5,409
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Installed a new chain

I put a new chain on my bike the day before yesterday and when I went riding yesterday it felt like I had a little road buzz. I checked to make sure everything was lined up, but didn't, or couldn't, find anything wrong. Does anybody have a clue what this could be. I feel it more when I'm putting more pressure on the pedals. Thanks for any help or suggestions.
__________________
George
George is offline   Reply With Quote
Old 06-25-07, 07:55 AM   #2
vpiuva
*
 
vpiuva's Avatar
 
Join Date: Jan 2007
Bikes:
Posts: 3,458
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
How many speeds on your bike? Shimano, Campy, other? What was your old chain, if you know. What is your new chain? Answers may help us start down the right path.
vpiuva is offline   Reply With Quote
Old 06-25-07, 08:11 AM   #3
George
Senior Member
Thread Starter
 
George's Avatar
 
Join Date: Jul 2006
Location: Katy Texas
Bikes: Specialized Roubaix
Posts: 5,409
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
It was a 9 speed Shimano chain and I went with the Sram, but I was just outside playing with it and I think it's the Shimano pedals which are the 520s. Thanks for reply.
__________________
George
George is offline   Reply With Quote
Old 06-25-07, 08:31 AM   #4
George
Senior Member
Thread Starter
 
George's Avatar
 
Join Date: Jul 2006
Location: Katy Texas
Bikes: Specialized Roubaix
Posts: 5,409
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
False alarm, it was the pedals. Thanks for the reply.
__________________
George
George is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 12:55 PM.