Advertise on Bikeforums.net



User Tag List

Results 1 to 6 of 6
  1. #1
    Apot. sshock4's Avatar
    Join Date
    May 2002
    Location
    new brunswick, nj
    Posts
    191
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    chain slipping on cassette...why?

    i just replaced my cassette and chain with new oens on my 9 speed drivetrain on my ells joker. i put on a pc59 chain and deore cassette to replace a 59 chain and a lx or xt cassette, i dunno. now whenever i crank hard the chain slips over the cassette. why?
    surly1x1

  2. #2
    Senior Member BikerRyan's Avatar
    Join Date
    Dec 2002
    Posts
    306
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    errrrrr, mis adjustment of the rear der. Not enough cable tension?

    -Ryan
    Your bike mechanic is wise beyond your wildest dreams.

    If you can't be good at one sport then you can be okay at three.

  3. #3
    Little Debbie Fiend Club KevinG's Avatar
    Join Date
    Apr 2001
    Location
    Back To New Orleans Again
    Posts
    697
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What did your LBS say?
    NADS #138
    Braaaaaaaaap!
    Go Medium Or Go HOME!!!!!
    Bob Roll:
    "Toour DAAAY Frantz!"

  4. #4
    1.64x10^6 posts Grendel's Avatar
    Join Date
    Aug 2002
    Location
    Spring, TX
    Posts
    501
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    New chain is too long, maybe?

  5. #5
    don d.
    Guest
    Could be a stiff link. Go to Barnett's Manuals thread at the beginning of this forum, go to chap 26, pages 3, 4. Will talk about stiff links. The whole chap. talks about chains.

  6. #6
    Apot. sshock4's Avatar
    Join Date
    May 2002
    Location
    new brunswick, nj
    Posts
    191
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    BikerRyan, i made sure the der was adjusted properly, i checked that a bunch, but thanks

    KevinG, i am my LBS....

    Grendel, thats my guess, i thought i had shortened it enough, but while in town this evening i thought about it and decided that was prolly the problem

    don d., no not a stiff link, the chain is new and was never reconnected with other then a powerlink.

    thanks everyone
    surly1x1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •