Advertise on Bikeforums.net



User Tag List

Results 1 to 3 of 3
  1. #1
    Senior Member
    Join Date
    Apr 2008
    Location
    A Latvian in Seattle
    Posts
    1,020
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    newbie disc rotor mount issue

    I've got a new Mavic Crossland front wheel with the CenterLock disc mount. I picked up a Shimano RT-53 160mm rotor, which (naturally!) fits nicely over the CenterLock splines. The lock ring threads in smoothly for the first turn or two, but then feels like it's hanging up. AFAI can tell, it's not misthreaded. The disc is still loose on the splines, so the lock ring needs to go in another turn or two. Is this normal -- I'm leery of forcing it? Do I perhaps need anti-seize or grease on the threads?

  2. #2
    Pwnerer Wordbiker's Avatar
    Join Date
    Jun 2005
    Location
    Pagosa Springs, CO, USA
    My Bikes
    Road, MTB, Cruiser, Chopper, BMX
    Posts
    2,900
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It could just be a burr from manufacturing. I'd try the grease/anti-seize and torque it to spec. If it's still wiggling then you have an issue to take up with warranty.
    Quote Originally Posted by ahsposo View Post
    Ski, bike and wish I was gay.

  3. #3
    Senior Member
    Join Date
    Apr 2008
    Location
    A Latvian in Seattle
    Posts
    1,020
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, a few dabs of antiseize did the trick! All torqued to spec now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •