Cycling and bicycle discussion forums. 
   Click here to join our community Log in to access your Control Panel  


Go Back   > >

Bicycle Mechanics Broken bottom bracket? Tacoed wheel? If you're having problems with your bicycle, or just need help fixing a flat, drop in here for the latest on bicycle mechanics & bicycle maintenance.

User Tag List

Reply
 
Thread Tools Search this Thread
Old 06-08-08, 02:24 PM   #1
anarcho-cyclist
Junior Member
Thread Starter
 
Join Date: Sep 2007
Bikes:
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Saddle Sliding, Need it to STAY PUT!

Hello,

So a few months back i got an easyseat from hobson seats, i love how it feels but there is a problem.
Ever since i installed it the saddle has a tendency to move back through out a ride, no more than 40 minutes and my saddle is in a very uncomfortable position. It only moves back, no tilting. i usally have to get off, adjust it and get back on.

How can i get it to stay in place?!

thanks!
anarcho-cyclist is offline   Reply With Quote
Old 06-08-08, 02:30 PM   #2
Retro Grouch 
Senior Member
 
Retro Grouch's Avatar
 
Join Date: Feb 2004
Location: St Peters, Missouri
Bikes: Catrike 559 I own some others but they don't get ridden very much.
Posts: 26,902
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 204 Post(s)
What kind of seatpost and clamp do you have?

If you have a straight seatpost and a separate clamp, make sure the size of the clamp matches the clamping area of your seatpost. If they don't go to an LBS and try to find a replacement that does. Then seriously snug that puppy down.
Retro Grouch is offline   Reply With Quote
Old 06-08-08, 04:16 PM   #3
mike
Senior Member
 
mike's Avatar
 
Join Date: Jul 2000
Location: Snowy midwest
Bikes:
Posts: 5,392
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Wow, the Easy Seat. I rode one of those for about a year and a half.

Mine was/is an original from 1970-something. I don't know if your hardware is the same as mine, but I did get it to work. I seem to remember it being problematic.

If your hardware is the same as mine, get yourself some star washers at the harware store. That should fix the problem. $0.59 cent fix with extras to spare.
Attached Images
File Type: jpg easy seat pic low pixel.jpg (3.1 KB, 3 views)
File Type: jpg easy seat box low pixel.jpg (5.3 KB, 4 views)

Last edited by mike; 06-09-08 at 04:18 AM.
mike is offline   Reply With Quote
Old 06-09-08, 10:14 AM   #4
anarcho-cyclist
Junior Member
Thread Starter
 
Join Date: Sep 2007
Bikes:
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have a seat post that has a clamp attached here is a picture of my set up.

Note the seat is in the exact WRONG position i want it to be, i should be a lot more forward.

One thing i do notice is that the seat clamp (which has a long metal part) doesn't fully clamp the seat stay. would getting a different post (one with only 2 points of contact) work better?
Attached Images
File Type: jpg DSCN2092.JPG (87.6 KB, 10 views)
anarcho-cyclist is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 02:42 PM.