Advertise on Bikeforums.net



User Tag List

Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Sep 2007
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Saddle Sliding, Need it to STAY PUT!

    Hello,

    So a few months back i got an easyseat from hobson seats, i love how it feels but there is a problem.
    Ever since i installed it the saddle has a tendency to move back through out a ride, no more than 40 minutes and my saddle is in a very uncomfortable position. It only moves back, no tilting. i usally have to get off, adjust it and get back on.

    How can i get it to stay in place?!

    thanks!

  2. #2
    Senior Member Retro Grouch's Avatar
    Join Date
    Feb 2004
    Location
    St Peters, Missouri
    My Bikes
    Rans Enduro Sport, Hase Kettweisel Tandem, Merin Bear Valley beater bike
    Posts
    23,899
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What kind of seatpost and clamp do you have?

    If you have a straight seatpost and a separate clamp, make sure the size of the clamp matches the clamping area of your seatpost. If they don't go to an LBS and try to find a replacement that does. Then seriously snug that puppy down.

  3. #3
    Senior Member mike's Avatar
    Join Date
    Jul 2000
    Location
    Snowy midwest
    Posts
    5,392
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Wow, the Easy Seat. I rode one of those for about a year and a half.

    Mine was/is an original from 1970-something. I don't know if your hardware is the same as mine, but I did get it to work. I seem to remember it being problematic.

    If your hardware is the same as mine, get yourself some star washers at the harware store. That should fix the problem. $0.59 cent fix with extras to spare.
    Attached Images Attached Images
    Last edited by mike; 06-09-08 at 04:18 AM.
    Mike

  4. #4
    Junior Member
    Join Date
    Sep 2007
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have a seat post that has a clamp attached here is a picture of my set up.

    Note the seat is in the exact WRONG position i want it to be, i should be a lot more forward.

    One thing i do notice is that the seat clamp (which has a long metal part) doesn't fully clamp the seat stay. would getting a different post (one with only 2 points of contact) work better?
    Attached Images Attached Images

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •