Cycling and bicycle discussion forums. 
   Click here to join our community Log in to access your Control Panel  


Go Back   > >

Bicycle Mechanics Broken bottom bracket? Tacoed wheel? If you're having problems with your bicycle, or just need help fixing a flat, drop in here for the latest on bicycle mechanics & bicycle maintenance.

User Tag List

Reply
 
Thread Tools Search this Thread
Old 07-08-08, 09:25 PM   #1
davidhowland14
Triathlete
Thread Starter
 
Join Date: Jul 2007
Location: Cape Cod, MA
Bikes: 05' DeVinci St. Tropez, 07' Trek 1500
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Squeaking and Motion in New Keo Sprints

I bought a new pair of Keo Sprint pedals last week, installed cleats and pedals, and took them out for their first ride yesterday morning. I noticed a squeak (of plastic on plastic), and a feeling of horizontal motion in the left pedal. I tightened the cleats on the shoes all th e way down, and I still feel the motion and hear the squeak. It's not the float in the pedals, although the squeak does change depending on the angle of my foot. Any ideas as to what could be causing the looseness in the left pedal? The right pedal snaps in tight and is silent. Thanks.
davidhowland14 is offline   Reply With Quote
Old 07-09-08, 02:55 AM   #2
Vanthel
Will ask stupid questions
 
Join Date: Jul 2008
Location: Cambridge/London - UK
Bikes: Specialized Allez Elite 2007
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I was going to suggest you have floating cleats but judging from your post you have 0 degree play cleats?
Vanthel is offline   Reply With Quote
Old 07-09-08, 05:30 AM   #3
davidhowland14
Triathlete
Thread Starter
 
Join Date: Jul 2007
Location: Cape Cod, MA
Bikes: 05' DeVinci St. Tropez, 07' Trek 1500
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
argh. no. The cleats have float. It is, however, not the float that is causing this. The motion is in a direction parallel to the bike. Both pedals float, obviously, and the right one does not squeak, and it does not move in a parallel direction to the bike.
davidhowland14 is offline   Reply With Quote
Old 07-09-08, 12:17 PM   #4
Vanthel
Will ask stupid questions
 
Join Date: Jul 2008
Location: Cambridge/London - UK
Bikes: Specialized Allez Elite 2007
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
oh I see, very odd :s sounds like cleat is too small or the pedal is slightly too long.. manufacturing fault? maybe try measuring the lengths between the two contact ends of the cleats and compare with the right one then same with the pedals..

That's all I can think of
Vanthel is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 07:32 PM.