Advertise on Bikeforums.net



User Tag List

Results 1 to 6 of 6
  1. #1
    Senior Member
    Join Date
    Mar 2008
    Posts
    97
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Shimano Sora Flight Deck Shifters -- Left side does not work

    I bought some Shimano Sora Flight Deck Shifters last week from a friend. These are the ones that have the thumb shifters.

    I have not built up my road bike yet, so I thought I'd just mount these shifters on the set of bars that I'm going to use.

    I was playing with the left shifter, and suddenly, I lose all "tension". This means that both the upshift and downshift shifters did not click at all. They still spring back to their resting position, but compared to the working right shifter, I do not get any clicks.

    I removed the top cap to check out the internals, but no luck. However, once or twice, it would work again. However, when I shifted down or up, it would not work again.

    Here's a video. Listen carefully for the clicks.

    http://www.youtube.com/watch?v=0kxxoJp3aXs

    Thanks everyone!

  2. #2
    Senior Member
    Join Date
    Mar 2008
    Posts
    97
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Update:

    I thought I had fixed it, but after about 3-4 shift cycles (upshifts/down), it wouldn't function again.

    It definitely has something to do with the spring on top, and the rectangular block (see pics). If I position it a certain way and move the shifters, I can feel and even HEAR it engage! Anyone have any knowledge on it.?


  3. #3
    Desert Flatlander
    Join Date
    Jan 2009
    Location
    Buckeye, AZ
    My Bikes
    2001 Trek Alpha 1000, Micargi Tahiti NX3 'The Iron Horse', and many other cheap resale and family bikes.
    Posts
    80
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Check out these: http://techdocs.shimano.com/techdocs...&bmUID=iHVsUnY

    They made it they probably know why it's not working. They usually have troubleshooting flowcharts too. I hope that you get yours working I have always liked mine.

    I've always wondered why these are called 'flight deck' when they don't include the computer. I used to think that they carried the 'flight deck' name because they had the shifters and brake levers together. Then one day I found out that there was a cyclocomputer offered with some of these sets. I would like to know more about this if someone is in the know.

  4. #4
    Senior Member
    Join Date
    Mar 2008
    Posts
    97
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Black Sunshine!

    Unfortunately, I did not see any troubleshoot links (only assembly and instructions).

    It almost seems like the spring pictured above is not in place correctly. I checked the other side, and the spring is sitting straight.

  5. #5
    Senior Member
    Join Date
    Mar 2008
    Posts
    97
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've uploaded another video. In this video, you can see that when I "reset" the spring with my finger, it operates perfectly. However, as you can also see, it only works for one shift cycle.

    http://www.youtube.com/watch?v=tI7hP7Lg3BI

  6. #6
    Newbie
    Join Date
    Sep 2011
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Did you ever fix this problem? I am having the same issue on a new bike I just got.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •