Advertise on Bikeforums.net



User Tag List

Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Apr 2008
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Look Keo axle/bearing problems

    Just purchased a new pair of Look Keo Carbon Blades (with Titanium axle).

    Only ridden about 100km/62mi in them, and the right pedal has developed a bit of play in the axle/bearing (where pedal connects to crank)- basically, you can wiggle the pedal slightly up/down and fore/aft with your fingers, whereas the left pedal is solid (as were my previous Shimano SPD/SL pedals). All the mountings seem to be tightly screwed on.

    Has anyone else had the same problem and have a fix?

  2. #2
    cab horn
    Join Date
    Jun 2004
    Location
    Toronto
    My Bikes
    1987 Bianchi Campione
    Posts
    28,295
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Those pedals have 'adjustable' bearings. Adjust them. It's also a common problem that we see quite often on the entry level Looks.
    Mes compaingnons cui j'amoie et cui j'aim,... Me di, chanson.

  3. #3
    Junior Member
    Join Date
    Apr 2008
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    How do I adjust them? I can't see any screw?

    The Look carbon blades are their top of the range pedal, would have thought they'd fix it.

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •