Advertise on Bikeforums.net



User Tag List

Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Jun 2008
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Speedplay pedal loose on spindle

    Today I noticed that the pedal body of one of my speedplay pedals can actually move about 5mm back and forth on the spindle. Does anyone know how to fix this?

  2. #2
    coprolite fietsbob's Avatar
    Join Date
    Jun 2010
    Location
    NW,Oregon Coast
    My Bikes
    7
    Posts
    3,368
    Mentioned
    50 Post(s)
    Tagged
    0 Thread(s)

  3. #3
    Senior Member
    Join Date
    Feb 2005
    Location
    Oklahoma
    My Bikes
    Trek 5500, Colnago C-50
    Posts
    9,209
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Which model of Speedplay do you have?

  4. #4
    coprolite fietsbob's Avatar
    Join Date
    Jun 2010
    Location
    NW,Oregon Coast
    My Bikes
    7
    Posts
    3,368
    Mentioned
    50 Post(s)
    Tagged
    0 Thread(s)
    NB: Service PDF for all of them there.

  5. #5
    Senior Member
    Join Date
    Aug 2005
    Location
    Pittsburgh, PA
    My Bikes
    '''96 Litespeed Catalyst, '05 Litespeed Firenze, '06 Litespeed Tuscany, '12 Surly Pacer, All are 3x8,9 or 10. It is hilly around here!
    Posts
    26,176
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Speedplay sells bearing replacement kits to repair worn or damaged pedals. Unfortunately, you have to go through a dealer as they refuse to sell directly to the consumer, even for small parts.

  6. #6
    30 YR Wrench BikeWise1's Avatar
    Join Date
    Aug 2005
    Location
    Oxford, OH
    My Bikes
    Waterford R-33, Madone 6.5, Trek 520
    Posts
    2,003
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by countryfried View Post
    Today I noticed that the pedal body of one of my speedplay pedals can actually move about 5mm back and forth on the spindle. Does anyone know how to fix this?
    How many miles on them? Have you been lubing them on schedule? They're not hard to rebuild.....

  7. #7
    Can'tre Member 3alarmer's Avatar
    Join Date
    Nov 2010
    Location
    ,location, location...
    My Bikes
    old ones
    Posts
    9,904
    Mentioned
    189 Post(s)
    Tagged
    4 Thread(s)
    Quote Originally Posted by fietsbob View Post
    I can't get your link to work, but this one should:

    http://www.speedplay.com/index.cfm?f...n=home.support
    Quote Originally Posted by CbadRider View Post
    Your friends on FB are very different than mine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •