Advertise on Bikeforums.net



User Tag List

Results 1 to 4 of 4

Thread: Bicycycle Pump

  1. #1
    King of Typos rickyhmltn's Avatar
    Join Date
    Aug 2011
    Location
    Kentucky
    My Bikes
    Trek 7.1 FX
    Posts
    149
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Bicycycle Pump

    Hey guys,

    I got a cheapo bike pump (i'm gonna upgrade) but in the meantime for the next couple of days when I use it, it's got a lot of resistance and no air goes into the tires. I'm sure its not the tires. I've placed the pump firmly over the schrader valve, and have also tried it on multiple tires. Any ideas?

  2. #2
    Senior Member
    Join Date
    Aug 2006
    Location
    NW AR & Central LA
    Posts
    2,543
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The pump head could be configured for a presta valve.

  3. #3
    King of Typos rickyhmltn's Avatar
    Join Date
    Aug 2011
    Location
    Kentucky
    My Bikes
    Trek 7.1 FX
    Posts
    149
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well I was using it on Schrader tires, then one day it just no longer pumps. A lot of resistance with no air going to the tubes.

  4. #4
    Senior Member
    Join Date
    Apr 2011
    Posts
    1,109
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If you pump it without putting it to a Schrader, or any, valve, does air come out? If yes, the thing that depresses and opens the Schrader valve might be busted and the air pressure generated is insufficient to open the valve. If that's the case, you can either try to fix the head, cut the head off and replace it, or replace the pump.

    Replacement heads...
    http://www.amazon.com/gp/product/B001CK2O3I
    http://www.jensonusa.com/store/produ...alve+Head.aspx
    Last edited by jsdavis; 11-21-11 at 12:40 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •