Cycling and bicycle discussion forums. 
   Click here to join our community Log in to access your Control Panel  


Go Back   > >

Bicycle Mechanics Broken bottom bracket? Tacoed wheel? If you're having problems with your bicycle, or just need help fixing a flat, drop in here for the latest on bicycle mechanics & bicycle maintenance.

User Tag List

Reply
 
Thread Tools Search this Thread
Old 03-09-05, 12:47 PM   #1
gonesh9
wonderer, wanderer
Thread Starter
 
gonesh9's Avatar
 
Join Date: Mar 2003
Location: portland, or
Bikes: surly crosscheck, yeti 575, salsa moto rapido, kona ute
Posts: 1,712
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
There's been a squeaky noise coming from the headset area that has gotten much worse lately. I've made sure the headset is tightened properly, and several bike shop dudes have also tightened it for me. The squeak comes when I apply force on one side of the handlebars (take on hand off) or when I hit a bump at an angle. So it seems like it's the steerer squaeking on the inside of the head tube or something? Or could it just be that I need a new headset? (2 year old Cane Creek.) It's getting really obnoxious.
__________________
Bicycle-eye
gonesh9 is offline   Reply With Quote
Old 03-09-05, 01:10 PM   #2
sydney
Senior Member
 
sydney's Avatar
 
Join Date: Jan 2004
Bikes:
Posts: 9,428
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by gonesh9
There's been a squeaky noise coming from the headset area that has gotten much worse lately. I've made sure the headset is tightened properly, and several bike shop dudes have also tightened it for me. The squeak comes when I apply force on one side of the handlebars (take on hand off) or when I hit a bump at an angle. So it seems like it's the steerer squaeking on the inside of the head tube or something? Or could it just be that I need a new headset? (2 year old Cane Creek.) It's getting really obnoxious.
The steerer cannot contact the headtube. Maybe it isn't even the HS?
sydney is offline   Reply With Quote
Old 03-09-05, 02:40 PM   #3
baxtefer
Cornucopia of Awesomeness
 
baxtefer's Avatar
 
Join Date: Oct 2004
Location: not where i used to be
Bikes:
Posts: 4,847
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
have you tried greasing the stem faceplate bolts?
and check your bars for cracks.
baxtefer is offline   Reply With Quote
Old 03-09-05, 04:38 PM   #4
greenpeter2001
Junior Member
 
Join Date: Mar 2005
Bikes:
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi,
had similar problem on my carbon road bike.
tried
1.greasing handle bar /stem mount
2.tightening stem bolt/s
3.tightening sti mounts
all to no avail
creak was getting worse and so was my nervouseness when going downhill!
then took forks off and examined with lens
located fine crack in left fork just above drop out
solution : back to manufacturer for warranty claim
greenpeter2001 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 08:46 PM.