Advertise on Bikeforums.net



User Tag List

Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Jul 2004
    Posts
    22
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    problem with red rubber seal in odyssey cassette hub - help?

    guys,

    just bought an odyssey cassette hub, and an odyssey 10t 1pc driver. when i removed the original cog drive mechanism, there was a red rubber seal that fell out. i assumed that i should use it with the 1pc driver as well, but when i do use it - placing it on that ridge just past the pawls, and putting it on the hub - and begin to tighten down the cone nut, the 1pc driver can barely turn at all! when i do this without the red seal/grommet, it turns beautifully.

    anyone experience this and figured out how to use the red seal?

    thanks.

  2. #2
    SPACE FOR RENT Jerry Garcia's Avatar
    Join Date
    Jun 2005
    Location
    dark side of the moon
    My Bikes
    05 kink Cielencki, ody LHD cassete hazard light rear,Ody Vandero front, kink og fork, primo tenderizers,fsa pig headset,ody linear slick cable,FSA nasty boy cranks
    Posts
    507
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Most people remove the red seal.

  3. #3
    member
    Join Date
    Oct 2004
    Location
    San Jose, CA
    My Bikes
    Solid AA
    Posts
    4,751
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You don't need the seal; I've had three Odyssey cassette hubs and I've never kept it on.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •