Bike Forums

Bike Forums (http://www.bikeforums.net/forum.php)
-   Electric Bikes (http://www.bikeforums.net/electric-bikes/)
-   -   Troubleshooting battery/charger? (http://www.bikeforums.net/electric-bikes/931906-troubleshooting-battery-charger.html)

Cybergooch 01-28-14 10:53 PM

Troubleshooting battery/charger?
 
Hi all,

I bought a Currie IZIP E3 Zuma CF Bike in 2012.

I'm having some problems with either my battery or the charger (or both) and I'm not sure how to troubleshoot the problem.

When I first got the bike and would charge the battery, I would hear the fan come on inside the charger, and the light on the charger would turn yellow (if I recall correctly) then it would charge for a few hours, and then the fan would turn off and the light on the charger would turn green. All charged up.

Now when I plug the battery into the charger, the fan never comes on and the light on the charger turns green, despite the battery being completely dead.
In addition, the light turns green when the battery isn't even attached!

Any ideas how I can verify if the problem lies with the charger or the battery?

Thanks

Ypedal 01-30-14 12:09 PM

First thing is to check the voltage of the batter at the charge port, and the discharge port ( if they are separate ) and report back.

it could be a number of things (* BMS, bad cell, fuse, connection, etc ) , but voltage is the first thing to know.

Cybergooch 01-30-14 12:28 PM

1 Attachment(s)
Thanks Ypedal.

Here's a shot of the ports:
http://bikeforums.net/attachment.php...hmentid=362120

Any combination of tests across the ports give me nothing. Dead. :(


All times are GMT -6. The time now is 07:55 PM.