Cycling and bicycle discussion forums. 
   Click here to join our community Log in to access your Control Panel  


Go Back   > >

Electric Bikes Here's a place to discuss ebikes, from home grown to high-tech.

User Tag List

Reply
 
Thread Tools Search this Thread
Old 01-28-14, 10:53 PM   #1
Cybergooch
Newbie
Thread Starter
 
Join Date: Jan 2014
Bikes:
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Question Troubleshooting battery/charger?

Hi all,

I bought a Currie IZIP E3 Zuma CF Bike in 2012.

I'm having some problems with either my battery or the charger (or both) and I'm not sure how to troubleshoot the problem.

When I first got the bike and would charge the battery, I would hear the fan come on inside the charger, and the light on the charger would turn yellow (if I recall correctly) then it would charge for a few hours, and then the fan would turn off and the light on the charger would turn green. All charged up.

Now when I plug the battery into the charger, the fan never comes on and the light on the charger turns green, despite the battery being completely dead.
In addition, the light turns green when the battery isn't even attached!

Any ideas how I can verify if the problem lies with the charger or the battery?

Thanks
Cybergooch is offline   Reply With Quote
Old 01-30-14, 12:09 PM   #2
Ypedal 
Senior Member
 
Ypedal's Avatar
 
Join Date: Oct 2008
Location: Moncton, NB, Canada
Bikes:
Posts: 111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
First thing is to check the voltage of the batter at the charge port, and the discharge port ( if they are separate ) and report back.

it could be a number of things (* BMS, bad cell, fuse, connection, etc ) , but voltage is the first thing to know.
Ypedal is offline   Reply With Quote
Old 01-30-14, 12:28 PM   #3
Cybergooch
Newbie
Thread Starter
 
Join Date: Jan 2014
Bikes:
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks Ypedal.

Here's a shot of the ports:


Any combination of tests across the ports give me nothing. Dead.
Attached Images
File Type: jpg battery_ports.jpg (96.8 KB, 3 views)
Cybergooch is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 05:14 AM.