Advertise on Bikeforums.net



User Tag List

Results 1 to 9 of 9
  1. #1
    Road Runner DougG's Avatar
    Join Date
    Sep 2003
    Location
    Rochester Hills, MI
    My Bikes
    Specialized Sequoia, Specialized Crosstrail, Cannondale Synapse Carbon
    Posts
    972
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Updating Edge 705 Firmware

    Instead of using the WebUpdater, I want to update my Edge 705, currently on 2.40, with 2.50 (the latest firmware is 2.60, which is reported to have some issues).

    Anyway, I have downloaded the update file, Edge605_705_250.gcd from the Garmin site, and it's my understanding that I just have to copy this to somewhere on the Garmin "drive" when it's connected to my PC, and on the next power-on the 705 will perform the update. So far I haven't had any luck with a couple locations that I've copied it to.

    Does anyone know this trick for manually applying an update?

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Location
    Sunny California
    My Bikes
    Madone 6.9 w/ Record Carbon, Look KG461, De Rosa
    Posts
    653
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What issues are you hearing about with regards to 2.6? I have been using it since the day it came out without any problems.

    What directories did you try placing the file in? I do know that placing it on the SD card will not work.

  3. #3
    Older than dirt CCrew's Avatar
    Join Date
    May 2008
    Location
    Winchester, VA
    My Bikes
    Too darn many.. latest count is 11
    Posts
    5,345
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Something wrong with WebUpdater? I use it on 3 units with never an issue. I can't understand why you choose to cause yourself extra pain.

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Sunny California
    My Bikes
    Madone 6.9 w/ Record Carbon, Look KG461, De Rosa
    Posts
    653
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    He is not wanting to install the latest update. WebUpdater will not allow you to install anything but the most recent version. The current version is 2.6. He wants 2.5 on his Edge.

    That is why I asked what bugs he is hearing about.

  5. #5
    Senior Member
    Join Date
    Oct 2005
    Location
    Sunny California
    My Bikes
    Madone 6.9 w/ Record Carbon, Look KG461, De Rosa
    Posts
    653
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Doug, are you rochrunner on the MotionBased forums? If so then you have probably read this response, it not here you go:

    You'll have to rename it to gupdate.gcd and put it in the garmin folder of the root directory on the Edge not the SD card. Discconnect the unit, turn it on and it will do the software update. Based on the experiences of previous FW updates you should do a hard reset after the unit finishes. Be sure to save history and note your screen layouts since they will revert back to the original display.

    Or, here is the link:
    http://forums.motionbased.com/smf/in...1234400106#new

  6. #6
    Junior Member ISSY's Avatar
    Join Date
    Feb 2009
    Location
    Rhode Island
    My Bikes
    BMC Pro Machine; Trek 6700
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I am having a somewhat similar problem. I received my 705 this morning. Everything with the unit seems to be ok. Picks up the satelite, records data, but I cannot get any of my computers to recognize the unit. MAC or PC. The unit software version is 2.4. I can't update it through the Webupdater because it doesn't see the unit. I cannot load new USB drivers for the same reason. When I have the unit powered on and connect the USB cable to it the unit powers off and the screen shows a PC with what I'm guessing is a picture of an 705 connected to it.
    Can anyone provide some help with this?

  7. #7
    juneeaa memba!
    Join Date
    Oct 2003
    Location
    boogled up in...Idaho!
    My Bikes
    Crap. The box is not big enough...
    Posts
    5,611
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you running vista 64? if so, it seems that you're SOL.

  8. #8
    Junior Member ISSY's Avatar
    Join Date
    Feb 2009
    Location
    Rhode Island
    My Bikes
    BMC Pro Machine; Trek 6700
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by luker View Post
    you running vista 64? if so, it seems that you're SOL.
    Actually I just took it upstairs and hooked it up to my 64bit machine......worked like a charm.

  9. #9
    juneeaa memba!
    Join Date
    Oct 2003
    Location
    boogled up in...Idaho!
    My Bikes
    Crap. The box is not big enough...
    Posts
    5,611
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I cannot get the garmin driver to register with vista 64. There's a bulletin on their site about it not working, so I didn't try further. You got the driver to install (um, training center can read the 705 device)?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •