Cycling and bicycle discussion forums. 
   Click here to join our community Log in to access your Control Panel  


Go Back   > >

Electronics, Lighting, & Gadgets HRM, GPS, MP3, HID. Whether it's got an acronym or not, here's where you'll find discussions on all sorts of tools, toys and gadgets.

User Tag List

Reply
 
Thread Tools Search this Thread
Old 03-22-09, 08:21 AM   #1
bernmart
Senior Member
Thread Starter
 
bernmart's Avatar
 
Join Date: Apr 2005
Location: Pasadena, CA
Bikes: Specialized Roubaix Pro
Posts: 813
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dead Garmin Edge 305

I've been using my 305 with great satisfaction for almost two years (the cadence sensor quit several months ago, but that's a different story). So after Friday's ride I downloaded the data to my computer, charged it fully, and put it back on the bike.

Yesterday AM I set out on a long ride, but the Garmin wouldn't turn on! Hasn't turned on since, and when hooked up to the charger there's no screen display of any kind. It's suddenly and without warning dead as a doornail.

What's to be done, if anything? It's surely out of warranty, and I can't contact Garmin by phone until Monday AM.
__________________
Specialized Roubaix Pro
Specialized Sequoia Elite
bernmart is offline   Reply With Quote
Old 03-22-09, 09:49 AM   #2
rodrigaj
Senior Member
 
rodrigaj's Avatar
 
Join Date: Jul 2006
Location: Madison, WI
Bikes:
Posts: 1,126
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Press the two halves together while trying to turn it on. If it turns on, you have the well documented press fit battery connection problem. Usually the turning-off will happen when you are riding. Initially once in a while then more often. Call Garmin. They will offer you a refurbished unit for about $100.

The problem stems from the way the unit is put together. The two halves are glued together, and there is a spring press connection to the battery that loosens over time. They corrected this problem in the Garmin 705, since the two halves are screwed together.
rodrigaj is offline   Reply With Quote
Old 03-22-09, 10:39 AM   #3
bernmart
Senior Member
Thread Starter
 
bernmart's Avatar
 
Join Date: Apr 2005
Location: Pasadena, CA
Bikes: Specialized Roubaix Pro
Posts: 813
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I tried it, and it's just as you said. I'll call them asap. Thanks, rodrigaj.
__________________
Specialized Roubaix Pro
Specialized Sequoia Elite

Last edited by bernmart; 03-22-09 at 01:09 PM.
bernmart is offline   Reply With Quote
Old 04-06-09, 01:01 PM   #4
SSSTANG
Senior Member
 
SSSTANG's Avatar
 
Join Date: Nov 2008
Location: Back in Middle Georgia
Bikes:
Posts: 116
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by bernmart View Post
I tried it, and it's just as you said. I'll call them asap. Thanks, rodrigaj.
What did Garmin have to say? It seems I may have he same problem.

Last edited by SSSTANG; 04-06-09 at 01:40 PM.
SSSTANG is offline   Reply With Quote
Old 04-06-09, 01:28 PM   #5
bernmart
Senior Member
Thread Starter
 
bernmart's Avatar
 
Join Date: Apr 2005
Location: Pasadena, CA
Bikes: Specialized Roubaix Pro
Posts: 813
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Via e-mail, at least, Garmin recommended a complete reset. I couldn't get it to reset. But, after pressing the two halves together and starting it several times, it's been working perfectly. So I'll wait for the next recurrence of the problem before contacting Garmin again.

The unit's well past warranty, so there doesn't seem to be much point in pressing the matter while the unit's working OK. Or maybe I'm just a wimp. Or both.

I hope this is some help.
__________________
Specialized Roubaix Pro
Specialized Sequoia Elite
bernmart is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 05:27 PM.