Bike Forums

Bike Forums (http://www.bikeforums.net/forum.php)
-   Electronics, Lighting, & Gadgets (http://www.bikeforums.net/electronics-lighting-gadgets/)
-   -   Garmin GPS shutting off randomly while riding (http://www.bikeforums.net/electronics-lighting-gadgets/531367-garmin-gps-shutting-off-randomly-while-riding.html)

CdCf 04-15-09 12:25 PM

Garmin GPS shutting off randomly while riding
 
I've had my Garmin eTrex Legend HCx for almost a year, and I've used it on a few rides to either record a track or find my way (sometimes both). Until last week, it's been rock solid. Never a glitch or power-off.

But this time (on a ride to my parents' house), I suddenly found it had shut itself off about 20-25 minutes into the ride. I turned it back on, and it was fine for another half hour or so, then it was off again.

The batteries were installed fresh the same morning, and the battery indicator still shows four bars (indicating full), after about 6-7 hours use since then, so that's not the issue.

I kept turning it back on several times during the ride (five hours) and it was doing a bit better near the end.

On my way back home yesterday, I had no need for it during the first two hours, but I turned it on after that. It shut off within a few minutes. Turned it back on again, and it stayed on for 20-30 minutes. When I powered it back up the third time, it was fine for the rest of the ride (couple of hours). I turned it off myself when I arrived here.

Now, the question is, has it become damaged by the vibrations from the road? It did seem to mostly turn off during the sections with slightly rougher surfaces. Then again, I've used it offroad a few times (rigid MTB) and several rides in the past have been on equally rough roads.

The handlebar mount is sturdy, but not very good at keeping the GPS unit firmly in its place, so it rattles quite a bit.

Help!

enine 04-15-09 12:45 PM

I have one of those, I've seen two issues listed on GPS forums. One is a firmware issue, if you use batteries like lithiums the higher voltage can trigger the overvoltage shutdown, they fixed it with a firmware change to make sure your up to date.
The other is on older models but is a connection between the back/battery holder and the pcb.
are you using garmin's handlebar mount, I ask because I was looking at it too but read that its not real sturdy.

CdCf 04-15-09 12:50 PM

No, I only use regular alkaline 1.5 V AA cells.

Yes, the Garmin mount. It's sturdy as hell, but it doesn't lock the unit down tight enough for it not to rattle and shake. Then again, the vibrations are probably converted from high frequency, low amplitude to low frequency, high amplitude. Whether that's good or bad, I'm not sure.

CdCf 04-15-09 01:37 PM

Updated to the latest device and chipset firmware (2.80 for both, it seems), and now it doesn't seem to think there are more than two satellites in the sky...

I've left it sitting in the window (I always get at least 5-6 sats there) now, so hopefully it will "find" them again eventually...

prathmann 04-15-09 01:47 PM

Many Garmin models have a problem with shutting down when you hit a bump. The problem in most cases is that one of the batteries momentarily loses contact with the connector and the unit powers down. I've cured the problem on my eMap by adding a little pad of foam packing material inside the battery cover which keeps the batteries from vibrating and losing contact.

CdCf 04-15-09 02:34 PM

Quote:

Originally Posted by prathmann (Post 8737297)
Many Garmin models have a problem with shutting down when you hit a bump. The problem in most cases is that one of the batteries momentarily loses contact with the connector and the unit powers down. I've cured the problem on my eMap by adding a little pad of foam packing material inside the battery cover which keeps the batteries from vibrating and losing contact.

Yeah, I was thinking along the same lines. Will try that next time.

And the satellite issue has sorted itself out. It sees seven of them now, lying in the window. Better than average! :)

ebrady 04-16-09 07:37 AM

I had the same issue on a 200K ride a couple of weeks ago with the GPSMap 76CSX.
After some research I came across these two posts

http://groups.google.com/group/rando...6061535d?hl=en
http://home.comcast.net/~crwgpsguy/site/?/page/Garmin_Vista_fix/

Apparently it is a known issue on multiple models, I have not implemented it yet but plan to do so if the failures continue...

I have the Garmin bike mount, it's pretty decent, however there is a lot of vibration that gets transferred into the GPS due to how it mounts. I ended up mounting it to a Minorua space bar to center the mount closer to the stem and used some Dealextreme rubber helmet mounts on the space bar to dampen the vibrations..

CdCf 04-16-09 08:40 AM

Hmm, if it's a simple loss of contact like that, then I don't have to worry. Don't think I feel like soldering anything...


All times are GMT -6. The time now is 10:37 PM.