Advertise on Bikeforums.net



User Tag List

Results 1 to 3 of 3
  1. #1
    ...into the blue...
    Join Date
    Aug 2004
    My Bikes
    Thorn Nomad 2, LHT, Jamis Quest, ....
    Posts
    436
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Anyone used the Busch/Muller Ride & Charge?

    Ride & Charge

    I've got one paired with a SRAM i-light (discussed in another thread). I was talking w/ Peter White about replacing the i-light as I get an annoying vibration at 12mph. Rather than just go ahead and sell me a new $250 hub, Peter has agreed to put a ride&charge on a bike on a stand and see if he can re-create the vibration using a Schmidt hub.

    In the meantime, anyone else use the ride&charge? If so, have you noticed such a vibration, and in either case what hub are you using?

    Cheers,
    pete

  2. #2
    Senior Member echotraveler's Avatar
    Join Date
    Aug 2009
    Posts
    1,790
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    that sounds very cool!

  3. #3
    Senior Member canopus's Avatar
    Join Date
    Mar 2009
    Location
    Kingwood, TX
    My Bikes
    1985 Cannondale SR300, 1985 Cannondale ST400, Gary Littlejohn Cruiser, BMX
    Posts
    1,207
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I would probably change my light and before changing the hub... especially if the ride and charge only works with the IXON... (Put the IXON up on the block and get a better one with a stand light)
    Can you describe the vibration and feel? Can you hear it? Is it only when the light is on or the ride and charge?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •