Bike Forums

Bike Forums (http://www.bikeforums.net/forum.php)
-   Electronics, Lighting, & Gadgets (http://www.bikeforums.net/electronics-lighting-gadgets/)
-   -   My Garmin 705 froze (http://www.bikeforums.net/electronics-lighting-gadgets/588773-my-garmin-705-froze.html)

LesMcLuffAlot 09-26-09 07:33 PM

My Garmin 705 froze
 
Hi there,

Anyone have this problem. I did a 3 hour ride today. Came home. Plugged my Garmin 705 into the charger. That was around 6:30pm this evening. At about 9:15pm I went to unplug it, as I'm going for a 2 hour ride at 10pm.

The normal battery charge screen wasn't showing. It's showing the boot-up screen that looks like this

GARMIN


EDGE705
Copyright 2002-2008
Garmin Ltd. or its susidiaries
SIRF Technology, Inc. 2008

I unplugged it from the charger. I tried to turn the power off with the power button. It won't turn off. It won't let me adjust the screen brightness. Nothing, it is totally frozen and I can't shut it off.

Any advice?

LesMcLuffAlot

MarvelousMark 09-26-09 07:41 PM

Try plugging it into the computer and accessing the drives. It might trigger a response. You could do a hard reset, but that'll wipe out your data.

Also, get the firmware updated to the latest version by using the webupdater. I know they've addressed some freezing in some of the updates.

LesMcLuffAlot 09-26-09 08:02 PM

Thank you for your post Mark,

I plugged it into my computer with the USB cable. The 705 screen lights up but my computer doesn't sense it's there.

This is the first problem I have had since I got it back in March. I wasn't going to do an update until January 1st 2010 so I wouldn't lose my data.

How do I do a hard reset? I can't even shut the thing off.

Going riding for 2 hours now. Stuck using my measely Timex Hrt monitor. I'm such a slave to my gps....lol

LesMcLuffAlot

LesMcLuffAlot 09-26-09 08:07 PM

I also just tried the Garmin updater program and it doesn't sense my 705 is there.

CCrew 09-26-09 09:40 PM

To hard reset the unit turn the unit off, hold down the mode button and turn the unit on. When the unit asks if you want to erase all user data, select yes. After resetting the unit, leave it with a clear view of the sky for about 30 minutes to acquire the satellite almanac. “
Do not worry You don’t loose Your saved rides data, only all screen settings and some other device settings will go away. Set it back to Your preferences and You’re done. Hard reset is suggested after software updates.

LesMcLuffAlot 09-26-09 10:19 PM

Quote:

Originally Posted by CCrew (Post 9750978)
To hard reset the unit turn the unit off, hold down the mode button and turn the unit on. When the unit asks if you want to erase all user data, select yes. After resetting the unit, leave it with a clear view of the sky for about 30 minutes to acquire the satellite almanac. ď
Do not worry You donít loose Your saved rides data, only all screen settings and some other device settings will go away. Set it back to Your preferences and Youíre done. Hard reset is suggested after software updates.


Thank you for the info,

Unfortunately I can't even turn the unit off. The power button does nothing. I think all I can do at this point is wait for the battery to die and charge it up again and see where I am at. Hopefully I can get it working again before my rides on Sunday.

I'll keep you all informed,

LesMcLuffAlot

Caad 8 09-27-09 03:03 AM

Well you could try this, sometimes my brother ipod freezes and he cant shut it off. Once it dies he charges it back up and it works again.

luv2climb 09-27-09 09:56 AM

Did you try a soft reset? (hold lap button for 3 secs)

Do you have an SD card in it, if so remove it?

LesMcLuffAlot 09-27-09 11:18 AM

Quote:

Originally Posted by luv2climb (Post 9752783)
Did you try a soft reset? (hold lap button for 3 secs)

Do you have an SD card in it, if so remove it?

Update...it's been over 13 hours and the battery is still not dead.

I can't do a soft reset. The unit is frozen in the boot-up screen None of the buttons respond. I still can't even turn the unit off. It is stuck on.

I took the sd card out, was one of the first things I tried. Nothing.

http://farm3.static.flickr.com/2626/...c8a7f98649.jpg
It's frozen on this screen.

LesMcLuffAlot 09-27-09 06:33 PM

Update.....Got back from my ride at 7:30. The battery had finally died. I plugged it into the charger and it seems to be charging up fine.

Keeping my fingers crossed.

LesMcLuffAlot 10-09-09 07:49 PM

Sorry didn't get back to you all. After a recharge it worked fine. I'm going to take the risk of not updating it till Jan. 1st/2010 so I don't lose all my mileage and training hours info for this year.


All times are GMT -6. The time now is 03:51 AM.