Bike Forums

Bike Forums (http://www.bikeforums.net/forum.php)
-   Electronics, Lighting, & Gadgets (http://www.bikeforums.net/electronics-lighting-gadgets/)
-   -   P7 going bonkers in the cold (http://www.bikeforums.net/electronics-lighting-gadgets/624342-p7-going-bonkers-cold.html)

macdonwald 02-24-10 09:40 PM

P7 going bonkers in the cold
 
At least I think it's the cold that's to blame. I've had my 8-mode P7 for about a year and this winter it started behaving very erratically--constantly changing modes, shutting off, then starting back up, flickering, etc. It's imperfectly correlated to going over bumps. I'm in Philly so by cold I just mean 15-30F.

Any ideas for what I can do to mitigate this?

Iowegian 02-25-10 12:01 AM

Electronics can change their behavior with temperature changes but I'd guess you have an intermittant contact somewhere. If you have access to a soldering iron try touching up all the solder joints. Also check any spring loaded parts to make sure they are making good contact.

ItsJustMe 02-25-10 09:19 AM

+1, I'd look for a bad contact, or a bad switch. That's the most likely effect of cold weather, metal and plastic shrinks, contacts pull apart, plastic and rubber gets stiff. Try just tightening up the threaded components inside.

macdonwald 02-25-10 10:29 AM

Thanks for the replies. I definitely don't have access to a soldering iron and wouldn't really know where to begin even if I did. But ItsJustMe, what do you mean by "tightening up the threaded components inside"?

Is there anything I could do on the know-how order of sticking a wad of aluminum foil in there to stabilize things?

ItsJustMe 02-25-10 11:21 AM

Often flashlights are held together by threaded components, and if they rattle loose, you get intermittent connections.

Look inside to see if there are threads on the inside with a piece of metal, perhaps with a couple of slots on the side, that looks like it's screwed into the threads. Get hold of those slots with something (ideally a spanner but whatever you've got) and see if you can tighten it.

exile 02-25-10 08:26 PM

I had the same problem macdonwald. Like ItsJustMe said make sure everything is tightend.

MY problem I found out was a faulty tailcap (at least that's what I think it was). Depending on where you bought it you may be able to get a replacement. I found out I really didn't need a 5 mode P7 and bought a 2 mode instead. Now if I hit a bump to hard it doesn't start cycling through the different modes, just one click and i'm back at Hi.

Ziemas 02-26-10 12:59 AM

My DX light did the same. It's due to a bad contact, thanks to the poor quality of these lights. I replaced mine with a quality light from Shining Beam and haven't looked back.


All times are GMT -6. The time now is 01:28 PM.