Advertise on Bikeforums.net



User Tag List

Results 1 to 4 of 4
  1. #1
    Senior Member tuxbailey's Avatar
    Join Date
    Jun 2009
    Location
    Columbia, MD
    My Bikes
    2005 Merlin Extralight - 2001 Jamis Ventura - 1990 Specialized Hard Rock (with original tires) - Burley D'Lite Double for my kid
    Posts
    1,295
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    My Edge 305 just died.

    I went out for a ride today and after i came home I plug in the 305 for recharging. I checked a bit later and it said "Battery Charge Complete." I unplug and left it on the table. After dinner I tried to connect to the PC to get the data and no response. Plug the wall charger in and no luck either.

    is it time for a new one?

    Edit: I pushed the USB cable into the unit a little harder and it came back to life. Flaky.
    Last edited by tuxbailey; 02-28-10 at 09:26 PM. Reason: Problem Resolved.

  2. #2
    Determined Survivor ejbarnes's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    My Bikes
    Cervelo RS, Specialized Transition, Kona Paddy Wagon, Giant MTB. Lots of bikes in the Garage.
    Posts
    169
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hold the reset button and then turn on the power. Or... Hold the start /stop button and turn it on.
    Life is short. Enjoy the ride.
    James

  3. #3
    Senior Member
    Join Date
    Apr 2008
    Location
    Colorado
    My Bikes
    Scott Road, Jamis, Tricross,
    Posts
    218
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ejbarnes View Post
    Hold the reset button and then turn on the power. Or... Hold the start /stop button and turn it on.
    +1
    Just went through the exact same experience as you a month ago, the reset did the trick and I'm back up and running. Everything has been fine since.
    You go where you look

  4. #4
    Senior Member tuxbailey's Avatar
    Join Date
    Jun 2009
    Location
    Columbia, MD
    My Bikes
    2005 Merlin Extralight - 2001 Jamis Ventura - 1990 Specialized Hard Rock (with original tires) - Burley D'Lite Double for my kid
    Posts
    1,295
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I think that was what made it work. I was trying to hold all the buttons randomly and it worked.

    Does anyone know the reasoning behind this?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •