Advertise on Bikeforums.net



User Tag List

Results 1 to 11 of 11
  1. #1
    Senior Member
    Join Date
    Jun 2009
    Location
    Austin
    Posts
    1,156
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    My magic shine quit, any advice?

    I bought a magicshine headlight back in November and it started acting funny a few weeks ago. Sometimes, I'd plug it in after a ride and the charger light would not go red, but I had run the light for at least an hour. This seemed hit or miss, and then I would plug the battery into the light and nothing (green button would not light). But then, I would plug the battery into the charger for just a second, and then I would plug the light back in and it worked fine. This was all hit or mis, sometime it worked fine, charged, etc.

    Now it's totally dead, the charger will not go to red and the light doesn't work either. When I plug in the light, the button flahes green for a split second, then nothing. If I unplug it and plug it back in, nothing (not even a flash). I can get it to flash again if I move it to the charger for a sec and plug it back in, it's like it is re-setting something, but I don't know if that means anything.

    Sorry for the lengthy explanation, but I was hoping someone could help pinpoint the problem. I'd like to just get a new battery, headlight, or charger rather then buying an entire new unit, but I'm not sure which part is bad.

    I've got an email into geoman, but I'm a month out of my 90 day warranty, so I'm probably out of luck there.

  2. #2
    Seņior Member ItsJustMe's Avatar
    Join Date
    Sep 2005
    Location
    Michigan
    My Bikes
    Windsor Fens, Giant Seek 0 (2014, Alfine 8 + discs)
    Posts
    11,815
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Sounds like the battery is dead, to me. But it could be that the light isn't working so the battery is just always fully charged.

    I'd put a meter on it to see where the battery is. Also you could try discharging it for a few hours into a 6 volt incandescent lamp or something else that would draw an amp or so, then see if it charges. Actually if it'll light a lamp at all, the battery is fine and it's the lamp.
    Work: the 8 hours that separates bike rides.

  3. #3
    Bike addict, dreamer AdamDZ's Avatar
    Join Date
    Nov 2009
    Location
    Queens, New York
    My Bikes
    Surly Disc trucker (DIY), Fuji Reveal 1.0 (DIY MTB), Specialized Roubaix
    Posts
    5,161
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Did you waterproof your battery? Have you tested the light? If you can come up with an adapter you can connect the light directly to the charger or any other 6-8V power supply to test it. If the light works then it's the battery. It's a known issue, the battery is not waterproof and there is small circuit inside, when it gets water inside the circuit board dies either gradually or instantly. The circuit can be replaced for under $10 shipped.

    Adam

  4. #4
    Senior Member rumrunn6's Avatar
    Join Date
    Jul 2008
    Location
    25 miles northwest of Boston
    My Bikes
    Bottecchia Sprint
    Posts
    12,467
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    what did geomangear say?
    cycling is like baseball ~ it doesn't take much to make it interesting

  5. #5
    Senior Member
    Join Date
    Jun 2009
    Location
    Austin
    Posts
    1,156
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by AdamDZ View Post
    Did you waterproof your battery? Have you tested the light? If you can come up with an adapter you can connect the light directly to the charger or any other 6-8V power supply to test it. If the light works then it's the battery. It's a known issue, the battery is not waterproof and there is small circuit inside, when it gets water inside the circuit board dies either gradually or instantly. The circuit can be replaced for under $10 shipped.

    Adam
    Thanks, This sounds like a battery issue. I actually got the light to fire up for 5 minutes last night, so I don't think it's the light. I didn't do anything to waterproof the battery and have ridden in some pretty nasty stuff the last couple months (and heavy rain right before I started having the problem).

    Where do I get the $10 circut to fix this (I assume Geoman, but I have not heard back from him yet)?

    So, assuming I get the battery fixed (or buy another one), what is the best way to waterproof them?

  6. #6
    Seņior Member ItsJustMe's Avatar
    Join Date
    Sep 2005
    Location
    Michigan
    My Bikes
    Windsor Fens, Giant Seek 0 (2014, Alfine 8 + discs)
    Posts
    11,815
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    If you got it to light for 5 minutes, I bet it's just got a bunch of water inside it. Dry it out and see what happens.

    First, remove the plastic wrap from the battery. Clean up any corrosion - I use a toothbrush and water - clean water won't hurt anything if it's already wet anyway. Wash out the corrosion.

    Leave the wrap off and let it dry.

    Once it's dry, try charging it as it sits there. If things are back to normal, wrap it back up using electrical tape or whatever. In the future, put it in a ziplock or something.
    Work: the 8 hours that separates bike rides.

  7. #7
    Bike addict, dreamer AdamDZ's Avatar
    Join Date
    Nov 2009
    Location
    Queens, New York
    My Bikes
    Surly Disc trucker (DIY), Fuji Reveal 1.0 (DIY MTB), Specialized Roubaix
    Posts
    5,161
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I covered this a while ago in this thread. You will find the related links there. This board is smaller than the one that comes with the original battery, but it works. I fixed my battery with it.

    To waterproof it, "paint" it with liquid electrical tape. You can get it from Home Depot or other HW store. Just pay attention to colors, I bough a green one first by mistake.

    BTW, cleaning and drying it didn't work for me but do try ItsJustMe's suggestions first.

    Adam
    Last edited by AdamDZ; 03-10-10 at 12:28 PM.

  8. #8
    Senior Member rumrunn6's Avatar
    Join Date
    Jul 2008
    Location
    25 miles northwest of Boston
    My Bikes
    Bottecchia Sprint
    Posts
    12,467
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    mine rides in a water bottle topped with 2 sandwich bags and 2 rubber bands. when it's pouring I wrap the connector with a couple winds of hockey tape
    Attached Images Attached Images
    cycling is like baseball ~ it doesn't take much to make it interesting

  9. #9
    Senior Member
    Join Date
    Jun 2009
    Location
    Austin
    Posts
    1,156
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Update - I cut open the battery and the circuit is totally corroded. I'm amazed it was working last week.

    I also got a message back from geomangear and they are going to warranty the unit, even though it's a bit out of the 90 day mfg warranty window. It's great to see companies standing behind their product. I will certainly take more care to prevent moisture in the new battery.

  10. #10
    Senior Member
    Join Date
    Jun 2009
    Location
    Austin
    Posts
    1,156
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Another update - I already received the new battery from Geomangear and everthing is workingn great. I just need to seal the new battery now.

    I'm really impressed with their customer service, exceeded any expectations I had. Many of these internet companies have great prices, but it's typically slow and painful if you have a problem. The light was technically out of warranty by about a month, but Geomangear sent me another battery and charger first class mail prior to even receiving my bad stuff (that I just sent on Friday).

  11. #11
    Seņior Member ItsJustMe's Avatar
    Join Date
    Sep 2005
    Location
    Michigan
    My Bikes
    Windsor Fens, Giant Seek 0 (2014, Alfine 8 + discs)
    Posts
    11,815
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Those old batteries are probably fine, just the wiring and circuitry are shot. Don't throw them out; keep them and dink around and see if you can wind up with a spare battery, or send them to one of us as a gift (not me, I already have a spare, though I'd be happy to try to fix it for you, as others have already offered).

    Personally at this point I think I would go to a P7 flashlight if I had to do it over. I've found that medium mode on a P7 is enough light for me, and that gives me a 90+ minute runtime, and flashlights ARE waterproof.
    Work: the 8 hours that separates bike rides.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •