Cycling and bicycle discussion forums. 
   Click here to join our community Log in to access your Control Panel  


Go Back   > >

Electronics, Lighting, & Gadgets HRM, GPS, MP3, HID. Whether it's got an acronym or not, here's where you'll find discussions on all sorts of tools, toys and gadgets.

Reply
 
Thread Tools Search this Thread
Old 10-04-10, 12:51 PM   #1
gholt
Senior Member
Thread Starter
 
Join Date: Sep 2006
Location: Layton, UT
Bikes: 2004 Giant OCR, 2002 Specialized Stumpjumper, 2008 Trek 6500 Disc
Posts: 686
Repair a L&M Vega

I have a L&M Vega that stopped working after I rode it in a rainstorm. I just could not turn it on.

It appears that the charger goes through the charge cycle and shows that it is completly charged, but I am unable to turn it on. I talked to L&M and they no longer carry parts for this light. So, I have taken the battery pack out and and it has a little bit of white power on some of the areas. It looks like corrosion you might get on a car battery.

So, has anyone experienced any similiar that they were able to fix. If so, let me know how / what you did.

I hate to trash it as it has been a great flashing light. and a small light.
gholt is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 11:08 AM.