Advertise on Bikeforums.net



User Tag List

Results 1 to 9 of 9
  1. #1
    Senior Member balto charlie's Avatar
    Join Date
    Aug 2004
    Location
    Baltimore/DC
    Posts
    2,442
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    new Magicshine user

    Just got the 900 lumen model. Impressively bright. 2 quick questions
    1) do you unplug the battery when not in use to eliminate the green light wasting battery life?
    2) The O ring is a little cumbersome to use as quick release. This will be even more difficult during winter. I need 2 bike per commute(train in the middle) so must remove the light 4x's per day. Anyone have a better way to mount and remove the light. I don't want a helmet mount as I already use that for my Fenix.
    Thanks, Charlie

  2. #2
    Junior Member
    Join Date
    Jul 2010
    Posts
    15
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by balto charlie View Post
    Anyone have a better way to mount and remove the light. I don't want a helmet mount as I already use that for my Fenix.
    Thanks, Charlie
    Here's a link with a solution I went with; this seems to work very well: http://www.el34world.com/Misc/bike/BikesLights38.htm - I'm using this on a handlebar and my helmet.

  3. #3
    One Man Fast Brick hubcap's Avatar
    Join Date
    Jun 2005
    Location
    Chicagoland
    My Bikes
    Specialized Langster, Bianchi San Jose, early 90s GT Karakoram, Yuba Mundo, Mercier Nano (mini velo), Nashbar Steel Commuter, KHS Tandemania Sport
    Posts
    1,121
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Charlie,
    I am exactly in the same boat as you regarding needing to transfer the light between two different bikes everyday. That is probably the biggest reason I have not tried out the Magicshine yet. If someone can point towards an easy solution that will not wear out too quickly, I might give one a go. Lockblocks have been real convenient for my flashlights.

  4. #4
    Seņior Member ItsJustMe's Avatar
    Join Date
    Sep 2005
    Location
    Michigan
    My Bikes
    Windsor Fens, Giant Seek 0 (2014, Alfine 8 + discs)
    Posts
    11,528
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    I don't always unplug. The little LED on the back draws 20ma, and sucks about 6 minutes of runtime from your battery per 24 hours.

    I unplug on the weekends, and of course I unplug a day a week for recharging. And if I feel like it, or have a ton of stuff in the pannier and want to just take the whole bag in instead of taking stuff out (the battery just lives in the bottom of the bag.

    If you don't have the O ring with a tab on it, those are nice and make removal/installation super fast. I dunno what GeoMan has, but DX has the O rings with pull tabs on them. I can't imagine any mount being faster. A slide mount might be AS fast.
    Work: the 8 hours that separates bike rides.

  5. #5
    Senior Member balto charlie's Avatar
    Join Date
    Aug 2004
    Location
    Baltimore/DC
    Posts
    2,442
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    @jdm5: looks like a possibility, I will look into it. Thanks

    @Itsjustme: thanks, I guess I'll leave it plugged in at night. Kinda strange though, as my basement glows the eerie green. The 'O" ring I got does not have a tab. A tab would be great but would still be difficult with gloves @ 3F degrees. I think I prefer velcro like on the 2 fish blocks. I am going to play around with the fish blocks, PVC pipe and the light to see what I can come up with. That or jdm5s method.

  6. #6
    Senior Member Richard Cranium's Avatar
    Join Date
    Jun 2002
    Location
    Deep in the Shawnee Forest
    My Bikes
    LeMond - Gunnar
    Posts
    2,786
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The little LED on the back draws 20ma, and sucks about 6 minutes of runtime from your battery per 24 hours.
    I've measured four MS lights (green light/idle current) and they all read between 5-10mA - I guess both of my meters are way off.

  7. #7
    Seņior Member ItsJustMe's Avatar
    Join Date
    Sep 2005
    Location
    Michigan
    My Bikes
    Windsor Fens, Giant Seek 0 (2014, Alfine 8 + discs)
    Posts
    11,528
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Richard Cranium View Post
    I've measured four MS lights (green light/idle current) and they all read between 5-10mA - I guess both of my meters are way off.
    Probably not. My MS is first generation, so it may have a different LED in it.
    Work: the 8 hours that separates bike rides.

  8. #8
    Senior Member balto charlie's Avatar
    Join Date
    Aug 2004
    Location
    Baltimore/DC
    Posts
    2,442
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    So here's what I did. Took my 2 fish block off of my handlebars and turned it sideways and mounter to my stem. I then took a small(3") piece of PVC (handlebar thickness) and put it across the top U/velcro strap on the 2 fish block. I then mounted my light onto the PVC. So I will release the velcro to take my 2 fish block/PVC/light off of the bike. Will test tomorrow and post.

  9. #9
    Senior Member balto charlie's Avatar
    Join Date
    Aug 2004
    Location
    Baltimore/DC
    Posts
    2,442
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Seemed to work. I removed the PVC pipe w/ magicshine light and reattached to the other bike which also has a 2 Fish Block. Bring on the darkness as I am ready.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •