Advertise on Bikeforums.net



User Tag List

Results 1 to 8 of 8
  1. #1
    .........
    Join Date
    Dec 2007
    My Bikes
    Cannondale R800, Curtlo S+S coupled custom road bike, Turner Burner
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    2 Magicshine's, switches on both don't work

    Hi all,

    I have 2 MS and on both of them the switches don't work, meaning that I now have to plug/unplug the connectors to work the lights, as well as no means of dimming/flashing etc.

    Anyone else experience this problem? Both lights were bought from Geoman late Nov/early Dec. last year.

    Thanks.

  2. #2
    Senior Member
    Join Date
    Aug 2007
    Posts
    382
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Have you contacted Geoman?

  3. #3
    .........
    Join Date
    Dec 2007
    My Bikes
    Cannondale R800, Curtlo S+S coupled custom road bike, Turner Burner
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by sd790 View Post
    Have you contacted Geoman?

    I'm going to email him tonight. I was just wondering if this was a common issue or my luck is cr@p.

  4. #4
    Senior Member
    Join Date
    Sep 2007
    Location
    Seattle
    My Bikes
    Litespeed, O'Brien, Specialized, Fuji
    Posts
    254
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes, contact Geoman, but if you want to look, the switch cover is just a silicone grommet-like thing. Perhaps it slipped from the switch. Pluck off the cover and see if you can operate the exposed switch normally.

  5. #5
    .........
    Join Date
    Dec 2007
    My Bikes
    Cannondale R800, Curtlo S+S coupled custom road bike, Turner Burner
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Litespeedlouie View Post
    Yes, contact Geoman, but if you want to look, the switch cover is just a silicone grommet-like thing. Perhaps it slipped from the switch. Pluck off the cover and see if you can operate the exposed switch normally.
    Just tried that but no luck, lots of clicking....no change (at least it's on full power when I do plug in the connectors).

  6. #6
    Senior Member Eclectus's Avatar
    Join Date
    Dec 2008
    Location
    Kansas
    My Bikes
    Cervelo RS, Specialized Stumpy, Schwinn 974
    Posts
    1,874
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Your MS is under recall, not for switch, but flaming battery risk. Model with defective battery pack was sold from July 09 to Nov 10. Contact Geoman on this. (They are trying to contact their customers.)

    http://www.geomangear.com/index.php?...dex&cPath=4_41

  7. #7
    Senior Member
    Join Date
    Sep 2009
    Location
    Evansville, IN
    My Bikes
    CAAD10 and TMR01 daily riders
    Posts
    161
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I bought one from DealExtreme. Connectors were DOA and dealing with DE is a PITA. Concluded that MS is a POS.
    2013 BMC TMR01 custom build, 2013 Cannondale F29er, 2012 Cannondale CAAD10 custom build
    2011 Specialized Crux, 1980 Palo Alto custom build

  8. #8
    Bike addict, dreamer AdamDZ's Avatar
    Join Date
    Nov 2009
    Location
    Queens, New York
    My Bikes
    Surly Disc trucker (DIY), Fuji Reveal 1.0 (DIY MTB), Specialized Roubaix
    Posts
    5,161
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I had two MS tail lights. Both were acting up from the beginning and died within three weeks. The middle LED and the switch stopped working. I had good luck with their headlights, however.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •