Advertise on Bikeforums.net



User Tag List

Results 1 to 3 of 3
  1. #1
    Senior Member JackoDandy's Avatar
    Join Date
    Jan 2013
    Location
    PNW - USA
    Posts
    226
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Garmin 705 - Replace Battery?

    Greetings!

    I have a 2 year old Garmin 705 that has recently started to display a 'Low Battery' indicator after an hour or so of use. Strangely, the device will keep running for an extended time after the warning but the battery indicator is very low.

    Has anyone had experience/thoughts on the replacement battery kits you see on eBay? Looks like for $20 I can get a kit to install a new battery.

    Thanks.

  2. #2
    Senior Member Looigi's Avatar
    Join Date
    Dec 2010
    Posts
    7,327
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    I've had that happen to mine. I let it run down until the unit shut off and then let it charge for 12+ hrs and it seems to be OK. It has a Li-Ion battery which shouldn't have memory issues so it's somewhat surprising that it worked. Maybe it reset the charger chip or something. You can give it a shot and see what happens.

    As for replacing batteries, here're a few links:

    http://www.batteryship.com/htmlos/ht...model=Edge+705
    http://www.newpower99.com/ProductDet...5&Show=ExtInfo
    https://forums.garmin.com/showthread...&p=372#post372
    http://www.batteryeducation.com/2011...tructions.html
    http://www.youtube.com/watch?v=gbS4QKi48TM
    http://blog.mtbguru.com/2008/11/06/s...rmin-edge-305/

  3. #3
    Senior Member JackoDandy's Avatar
    Join Date
    Jan 2013
    Location
    PNW - USA
    Posts
    226
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Looigi View Post
    I've had that happen to mine. I let it run down until the unit shut off and then let it charge for 12+ hrs and it seems to be OK. It has a Li-Ion battery which shouldn't have memory issues so it's somewhat surprising that it worked. Maybe it reset the charger chip or something. You can give it a shot and see what happens.

    As for replacing batteries, here're a few links:

    http://www.batteryship.com/htmlos/ht...model=Edge+705
    http://www.newpower99.com/ProductDet...5&Show=ExtInfo
    https://forums.garmin.com/showthread...&p=372#post372
    http://www.batteryeducation.com/2011...tructions.html
    http://www.youtube.com/watch?v=gbS4QKi48TM
    http://blog.mtbguru.com/2008/11/06/s...rmin-edge-305/
    Thanks - thats the weird thing. If I ignore the message, the unit keeps running!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •