Advertise on Bikeforums.net



User Tag List

Results 1 to 8 of 8
  1. #1
    Senior Member sparks_219's Avatar
    Join Date
    Sep 2004
    Location
    Hamilton, Ontario
    My Bikes
    Rocky Mountain Instinct, Cannondale Six13, Cervelo One
    Posts
    646
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    OT: Logitech MX900 Problem!!

    I bought the Logitech MX900 bluetooth mouse on sale, and it works very well for a wireless mouse. I have the newest drivers and software from the Logitech's Website, and I have options to configure all the options that I want.

    However, the thumb buttons (forward/backward) does not work with Mozilla Firefox 1.0PR or Mozilla 1.7. They do work with IE. This is the most important feature I look for in a mouse, and I only use Firefox.

    Does anyone have any idea on how to solve this??

    Thanks

    Ming

  2. #2
    Non Tribuo Anus Rodentum and off to the next adventure (RIP) Stacey's Avatar
    Join Date
    Dec 2002
    Posts
    9,163
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    'Forward/backward" ? You mean paging back and up or scrolling up & down? Ether way, geez, I can't see how it's a big problem.



    Back when I first got started in computers we were lucky to even have a mouse. Yes sir, I''ll tell you times were tough, sometines we shared even our mouses. Untill we found out that't how viruses were spread.

  3. #3
    Just give'er. hooligan's Avatar
    Join Date
    Nov 2003
    Location
    Toronto
    My Bikes
    04 Scrap
    Posts
    1,890
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Mice. not mouses.

  4. #4
    Senior Member sparks_219's Avatar
    Join Date
    Sep 2004
    Location
    Hamilton, Ontario
    My Bikes
    Rocky Mountain Instinct, Cannondale Six13, Cervelo One
    Posts
    646
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Stacey
    'Forward/backward" ? You mean paging back and up or scrolling up & down? Ether way, geez, I can't see how it's a big problem.
    I'm talking about the buttons circled in the picture below. These just allow me to go back and forth between my browing history. Kinda annoying to move the cursor all the way up to the top to go back a page when you're used to using the buttons.


    I just fixed the problem by assigning keystrokes to the buttons. Because you can go back and forth by pressing alt + <- or alt + -> . I just assigned those key combos to the buttons


    Ming
    Last edited by sparks_219; 12-29-04 at 09:42 AM.

  5. #5
    Senior Member
    Join Date
    Jul 2002
    Location
    Ohio
    Posts
    245
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Have you tried uninstalling the software? I have had a Mx700, and a MX1000 and i run them both without the software. and everything works with firefox

  6. #6
    Non Tribuo Anus Rodentum and off to the next adventure (RIP) Stacey's Avatar
    Join Date
    Dec 2002
    Posts
    9,163
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by hooligan
    Mice. not mouses.

    Why thank you for noticing my levity.

  7. #7
    Campy or bust :p cryogenic's Avatar
    Join Date
    Oct 2004
    Location
    Knoxville, TN
    My Bikes
    Surly Karate Monkey commuter build
    Posts
    3,139
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    actually, you have to set the buttons to be the keystrokes ALT+Left arrow and ALT+Right arrow for back & forward. It's a known issue and nobody's bothered to fix it yet.

  8. #8
    Senior Member sparks_219's Avatar
    Join Date
    Sep 2004
    Location
    Hamilton, Ontario
    My Bikes
    Rocky Mountain Instinct, Cannondale Six13, Cervelo One
    Posts
    646
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by cryogenic
    actually, you have to set the buttons to be the keystrokes ALT+Left arrow and ALT+Right arrow for back & forward. It's a known issue and nobody's bothered to fix it yet.
    Hehehe...thanks

    I've already done that a while back indicated by the above post. Now everything is working, this is the best mice I've ever had! I used another type of bluetooth mice by Targus before, but this one is worlds better!!!

    Ming

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •