Cycling and bicycle discussion forums. 
   Click here to join our community Log in to access your Control Panel  


Go Back   > >

General Cycling Discussion Have a cycling related question or comment that doesn't fit in one of the other specialty forums? Drop on in and post in here! When possible, please select the forum above that most fits your post!

User Tag List

Reply
 
Thread Tools Search this Thread
Old 08-06-09, 11:38 PM   #1
Nimitz87
Senior Member
Thread Starter
 
Nimitz87's Avatar
 
Join Date: Jul 2008
Location: Cooper City, Fl
Bikes: Cannondale CAAD9 R5
Posts: 765
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
CS200 Polar problem after replacing battery?

I've had my computer for about a year, got the low batt sign on tuesday on a group ride, open it up replace it and make sure the o-ring is seated properly, and now the computer will randomly turn off almost as if the battery isn't making contact or something...

yesterday it was perfect on the ride...today it reset 3x on the ride...this is getting old real quick, anyone have any clue what's wrong?

I bought it from performance...how are they on returns/exchanges?

Chad
Nimitz87 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 04:13 PM.