Advertise on Bikeforums.net



User Tag List

Results 1 to 2 of 2
  1. #1
    Newbie
    Join Date
    Apr 2009
    Location
    Derby
    My Bikes
    Olmo 600 Ultegra Mavic Campag.....
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Help Shimano Ultegra 600 STi levers

    Hi all,

    can anyone help with any instructions for setting these up? I have just bought a lovely Olmo, well fitted out with good kit, but the STi's aren't ratcheting in to position. I've been told by one person they may need replacing, but wanted to check first they are set properly. Seems odd that both are not working, I think someones been fiddling..

    Thanks, Adam

  2. #2
    Newbie
    Join Date
    Apr 2009
    Location
    Derby
    My Bikes
    Olmo 600 Ultegra Mavic Campag.....
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    OOPs sorry

    Sorry folks, got carried away with a question I wanted to ask and missed the fact I was in introductions...

    Great site and looking forward to using it ........ ;0)

    Adam H

    Quote Originally Posted by Adam H View Post
    Hi all,

    can anyone help with any instructions for setting these up? I have just bought a lovely Olmo, well fitted out with good kit, but the STi's aren't ratcheting in to position. I've been told by one person they may need replacing, but wanted to check first they are set properly. Seems odd that both are not working, I think someones been fiddling..

    Thanks, Adam

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •