Cycling and bicycle discussion forums. 
   Click here to join our community Log in to access your Control Panel  


Go Back   > >

Introductions Welcome to the BikeForums community! Please introduce yourself to other forum members here.

User Tag List

Reply
 
Thread Tools Search this Thread
Old 03-21-10, 10:44 AM   #1
amkaos
Member
Thread Starter
 
Join Date: Mar 2010
Bikes:
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
brake lever sluggish upon release

hi:
brand new to biking and forum.
glad to be here
thanx

sorry for wrong title.. couldnt edit it

Last edited by amkaos; 03-21-10 at 10:48 AM.
amkaos is offline   Reply With Quote
Old 03-21-10, 11:01 AM   #2
jmurray01
Junior Member
 
Join Date: Mar 2010
Location: Findochty, Scotland!
Bikes: Universal 5 speed
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
So you have no problem with your brake lever? If you do then its simply the allen-key (Hex) screw on the bace of the lever thats too tight. WELCOME TO THE FORUM
jmurray01 is offline   Reply With Quote
Old 03-21-10, 03:49 PM   #3
NCMTBIKER
Double Rainbow....
 
NCMTBIKER's Avatar
 
Join Date: Oct 2009
Location: Lowgap,NC
Bikes: 2012 Trek/Gary Fisher Wahoo 29r Hardtail
Posts: 1,598
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Welcome to BF!!!Im sure u can find an answer to your problem on here
NCMTBIKER is offline   Reply With Quote
Old 03-21-10, 06:26 PM   #4
Suzie Green
Cycler
 
Suzie Green's Avatar
 
Join Date: May 2008
Bikes:
Posts: 1,499
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Welcome to the forum. I'm not the most intelligent mechanic on the planet, but my guess would be that you might need a new internal brake cable. Sometimes they get a bit corroded after time and lose their ability to slide back and forth without sticking. It's definitely happened to me before!
Suzie Green is offline   Reply With Quote
Old 03-27-10, 06:03 PM   #5
amkaos
Member
Thread Starter
 
Join Date: Mar 2010
Bikes:
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cable was not free and i unbound it and adjusted brakes from utube etc.. all is well now.
thanx
amkaos is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 11:05 AM.