Advertise on Bikeforums.net



User Tag List

Results 1 to 9 of 9
  1. #1
    Senior Member
    Join Date
    Aug 2009
    Location
    Portland, OR
    My Bikes
    Gunnar Roadie, Yeti 575
    Posts
    51
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Garmin Edge 705 in Portland????

    I was wondering if anyone uses an Edge 705 (or any garmin gps for that matter) here in the NW? I am thinking about getting one, but want to know if anyone has had any problems with them and the weather. Specifically, on overcast winter days does it get good reception? Also, how about using them in the rain here? Any other problems?

  2. #2
    Afterburners...good idea Sapling's Avatar
    Join Date
    Mar 2005
    Location
    Washington
    My Bikes
    Lemond Zurich
    Posts
    280
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Flawless performance in light to heavy rain last Saturday (Tacoma area).

  3. #3
    Senior Member
    Join Date
    Feb 2009
    Location
    Tacoma, WA
    Posts
    158
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Teammate has a 705 and has no problems in all kinds of weather. check out the log here...

    http://connect.garmin.com/explore?owner=malaholic

    if you click on a ride and scroll near the bottom, you'll see the model and version of garmin.

  4. #4
    Squeaky Wheel woodway's Avatar
    Join Date
    Nov 2008
    Location
    Woodinville, WA
    Posts
    1,328
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I ride with a Edge 705, both road and mountain biking. I've never had a problem with a GPS lock under clouds, trees or in the rain...

  5. #5
    Training Issaquatch's Avatar
    Join Date
    Dec 2008
    Location
    Issaquah, WA
    My Bikes
    2015 Focus Mares CX, 2008 Cannondale Supersix
    Posts
    293
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have a 705. It has worked flawlessly in all weather. No problems picking up signals anywhere except the underground parking garage at work.

  6. #6
    Senior Member Daveyboy's Avatar
    Join Date
    Mar 2006
    Location
    Everett area
    My Bikes
    Roubaix S-Works SL2, Redline Conquest
    Posts
    385
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Just took my 705 out for a spin today, it was cloudy with occassional rain. Worked perfectly.

  7. #7
    **** that mattm's Avatar
    Join Date
    Dec 2006
    Location
    CALI
    Posts
    11,490
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    Haven't had any problems with my 705, after about 7k miles on it last year. Lotsa rain.
    cat 1.

    blog

  8. #8
    Senior Member Old'N'Slow's Avatar
    Join Date
    Sep 2007
    Location
    Newcastle, WA
    My Bikes
    Serotta Concourse
    Posts
    52
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've only had one issue, so take this with a huge grain of salt. On my ride to work this past Monday, I was in thick, pea-soup type fog and the % grade indicator stopped functioning. On the afternoon ride home, it was clear and the indicator was working again. Really uncertain if the fog was to blame - who knows, but other than that one instance, the unit has been brilliant.
    It's time to ride...

  9. #9
    Senior Member
    Join Date
    Aug 2009
    Location
    Portland, OR
    My Bikes
    Gunnar Roadie, Yeti 575
    Posts
    51
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Awesome, thanks for all the input. Looks like ill be getting myself a new toy! However, anyone have any experience or preference with refurbished vs. new? Its hard to pass up these on ebay for $358 that have cadence included.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •