Advertise on Bikeforums.net



User Tag List

Results 1 to 4 of 4
  1. #1
    Senior Member
    Join Date
    Sep 2009
    Posts
    56
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question: A frame screw is stripped

    Hi guys -

    I've been gettng into cross, and have used this forum as a resource for learning about equipment, training, etc. It's been cool. I have a pretty basic question.

    I'm going to put a pump mount on the inside of the frame of my bike ('01 poprad frame), and one of the screws is stripped. It isn't coming out.

    Any suggestions on how I can get it out of there without screwing anything up? Here's a picture of it. Top screw is out, bottom screw, well, isn't.

    http://i282.photobucket.com/albums/k...wMjYtMTkyO.jpg

    Thanks

  2. #2
    Junior Member
    Join Date
    Apr 2009
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If the hex head itself is just stripped, use some vise grips clamping straight on the bolt but not going all the way back to the frame so you won't mar the paint. You could always put a little masking tape around the bolt head if you're worried about scratches. If it hasn't been out ever or in awhile tap the bolt lightly a few times with the backside of your pliers as the vibrations will loosen the bolt. Then get yourself a new one of the appropriate diameter, thread pitch and length at your local hardware store, though if you install a pump, chances are the mount will have new bolts. Good luck.

  3. #3
    Senior Member
    Join Date
    Sep 2009
    Posts
    56
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks. Problem is, it's not the head, it's the threads. The screw turns around in the frame, just doesn't come out. I'm not in a huge hurry, so haven't grabbed ahold and pulled with pliers yet - I don't want to screw up the frame if it's the screw that's hosed rather than the frame threads.

  4. #4
    Junior Member
    Join Date
    Jul 2009
    Location
    Ann Arbor, MI
    My Bikes
    09 Kona Dew
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have the exact same problem on my Kona Jake. I took the bottle cage off for a race and screwed the bolts back in. after the race, one bolt came right out...the other is stuck. just spinning in its little hole like an IDIOT.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •