Advertise on Bikeforums.net



User Tag List

Results 1 to 2 of 2
  1. #1
    Banned.
    Join Date
    Jul 2009
    My Bikes
    4
    Posts
    248
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    rollers troubleshooting (screeching)

    my bike rollers are making this awful screeching sound. its coming from the band that connects the front roller to the back. the back roller isn't gripping the band and the band (and front roller) stay put while the back one spins and screeches. how do i fix this? new band? i bought this unit from someone on craigslist.

  2. #2
    Bicycle Evangelist BeSelfPropelled's Avatar
    Join Date
    Jul 2012
    Location
    Charlottesville, VA
    My Bikes
    Schwinn Home Grown Hard Tail, Schwinn Home Grown 4 Banger, Torelli Spada Road Bike, Santana Arriva Tandem, Dyno Cruiser - Single Rider Tandem Length Crusier, Trek 400 - My Commuter Bike
    Posts
    46
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    A new band should fix it. If the band is left on the rollers all of the time they tend to get stretched out. After I use my rollers I take the band off of the rollers on both sides and also off of one side of the "killer head wind" attachment, if you have one. You gotta love the picture Kreitler puts on the killer head wind unit. Especially since you're looking at it while your riding.

    Roller1.jpgRoller2.jpg

    Johnny P Be Self Propelled

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •