Cycling and bicycle discussion forums. 
   Click here to join our community Log in to access your Control Panel  


Go Back   > >

Triathlon Swim / Bike / Run your thing? Drop in our new triathlon forum for the latest in training & gear. From beginner to expert, and sprint to ironman.

User Tag List

Reply
 
Thread Tools Search this Thread
Old 02-07-10, 05:19 PM   #1
exRunner
Senior Member
Thread Starter
 
exRunner's Avatar
 
Join Date: Feb 2009
Location: Long Island NY
Bikes: Panasonic 500
Posts: 750
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
USAT.COM No such thing

Anyone have the history details on this? I just renewed my membership and it occured to me that they don't own their name web address.
exRunner is offline   Reply With Quote
Old 02-07-10, 05:24 PM   #2
jetta-the-hut
Senior Member
 
jetta-the-hut's Avatar
 
Join Date: Jul 2009
Bikes:
Posts: 216
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
your right its not USAT.COM its usatriathlon.org at least thats where I renewed mine. Its also linked to the US Olypmics website.
jetta-the-hut is offline   Reply With Quote
Old 02-07-10, 06:03 PM   #3
sirious94
Senior Member
 
Join Date: Dec 2008
Bikes:
Posts: 697
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
you could always google USAT
sirious94 is offline   Reply With Quote
Old 02-07-10, 06:28 PM   #4
exRunner
Senior Member
Thread Starter
 
exRunner's Avatar
 
Join Date: Feb 2009
Location: Long Island NY
Bikes: Panasonic 500
Posts: 750
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Strange. If you google usat you end up at usatriathlon.org, but when you go to renew from that site you end up at multisports.hangastar.com.

Here is what has me worried. I can log into hangastar and see my renewal, but I can not log into usatriathlon. And, my new membership number is 3 digits longer than my old one and will not work on the first web site I tried to use it on (too many characters).

I fear I have screwed up somewhere, but I can't seem to figure it out. Online banking shows the correct charges from the correct people, so I may just be missing something.
exRunner is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 02:18 AM.