Go Back  Bike Forums > Bike Forums > Bicycle Mechanics
Reload this Page >

Clicking sound from Steer tube Clamp Area

Bicycle Mechanics Broken bottom bracket? Tacoed wheel? If you're having problems with your bicycle, or just need help fixing a flat, drop in here for the latest on bicycle mechanics & bicycle maintenance.

Clicking sound from Steer tube Clamp Area

Old 06-06-17, 12:03 AM
  #1  
J.Drop
Senior Member
Thread Starter
 
Join Date: Apr 2012
Location: Vancouver BC
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Clicking sound from Steer tube Clamp Area

Hey guys my bike recently developed a clicking sound from steer tube clamp area. It goes away every time I tighten up the top cap and re-torque the pinch bolts to spec, but comes back after a few rides. I checked over the stem and there does not seem to be any cracks. What else should I be looking at. It is getting really annoying having to re-torque every few rides just to get a silent bike.
J.Drop is offline  
Old 06-06-17, 01:11 AM
  #2  
hueyhoolihan
Senior Member
 
Join Date: Dec 2010
Location: Above ground, Walnut Creek, Ca
Posts: 6,682

Bikes: 8 ss bikes, 1 5-speed touring bike

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 86 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
i would remove the top adjusting cap. leave it at home and ride it like that, just to eliminate a variable.
hueyhoolihan is offline  
Old 06-06-17, 06:30 AM
  #3  
Slash5
Senior Member
 
Join Date: Feb 2014
Location: Southern Ontario
Posts: 1,888
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 258 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
If you remove the top cap, is there enough space between the steerer and the top of the stem? Should be at least 3 mm.
Slash5 is offline  
Old 06-07-17, 10:24 PM
  #4  
J.Drop
Senior Member
Thread Starter
 
Join Date: Apr 2012
Location: Vancouver BC
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
2nd ride and still no noise...... Really hope its just the top cap
J.Drop is offline  
Old 06-08-17, 08:30 AM
  #5  
corrado33
Senior Member
 
Join Date: Jun 2013
Location: Bozeman
Posts: 4,096

Bikes: 199? Landshark Roadshark, 198? Mondonico Diamond, 1987 Panasonic DX-5000, 1987 Bianchi Limited, Univega... Chrome..., 1989 Schwinn Woodlands, Motobecane USA Record, Raleigh Tokul 2

Mentioned: 24 Post(s)
Tagged: 0 Thread(s)
Quoted: 1125 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
I had a similar issue that I fixed by tightening the bolt that holds my brifters on.
corrado33 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
PigGirl
Blogger's Forum
0
08-17-09 07:44 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.