Go Back  Bike Forums > Bike Forums > Bicycle Mechanics
Reload this Page >

Is this because of dirt within the free hub?

Notices
Bicycle Mechanics Broken bottom bracket? Tacoed wheel? If you're having problems with your bicycle, or just need help fixing a flat, drop in here for the latest on bicycle mechanics & bicycle maintenance.

Is this because of dirt within the free hub?

Old 01-06-21, 05:18 AM
  #1  
Ev0lutionz
Senior Member
Thread Starter
 
Join Date: Aug 2020
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Liked 5 Times in 2 Posts
Is this because of dirt within the free hub? Weird sound when back peddling/moving wh



Ev0lutionz is offline  
Old 01-06-21, 12:49 PM
  #2  
Litespud
Senior Member
 
Join Date: Oct 2017
Location: Chapel Hill NC
Posts: 1,282

Bikes: 2000 Litespeed Vortex Chorus 10, 1995 DeBernardi Cromor S/S, Nashbar 3sp commuter

Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 474 Post(s)
Liked 506 Times in 283 Posts
Not sure what I'm looking at - there's some degree of engagement lag, but that could be either the design of the free hub (ie, low tooth count) or crap/hardened grease in the workings - otherwise is seems to be engaging and in the right direction. Was there some sound going with the videos?
Litespud is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.