Go Back  Bike Forums > Bike Forums > Bicycle Mechanics
Reload this Page >

Shimano ultegra di2 help

Notices
Bicycle Mechanics Broken bottom bracket? Tacoed wheel? If you're having problems with your bicycle, or just need help fixing a flat, drop in here for the latest on bicycle mechanics & bicycle maintenance.

Shimano ultegra di2 help

Old 03-11-21, 07:23 AM
  #1  
Junpogs
Newbie
Thread Starter
 
Join Date: Mar 2021
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Shimano ultegra di2 help

I recently finished the build of my bike and on to setting up my di2 groupset. Its a full Ultegra R8000 di2 groupset. With the newest battery and the BL module installed.

When I press and hold the button on the junction box for about 1 sec it will go to the adjustment mode. When I press longer it will start blinking for a few times only the red led. Then just stops. I can't seem to go on the pairing mode where both the green and red leds will blink. Also when I double press the button nothing happens. So I cannot even switch between shift modes.

What could be the problem here? TIA
Junpogs is offline  
Old 03-11-21, 09:26 AM
  #2  
Steve B.
Senior Member
 
Join Date: Jul 2007
Location: South shore, L.I., NY
Posts: 6,059

Bikes: Flyxii FR322, Cannondale Topstone, Miyata City Liner, Specialized Chisel, Specialized Epic Evo

Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 2656 Post(s)
Liked 1,409 Times in 816 Posts
Originally Posted by Junpogs View Post
I recently finished the build of my bike and on to setting up my di2 groupset. Its a full Ultegra R8000 di2 groupset. With the newest battery and the BL module installed.

When I press and hold the button on the junction box for about 1 sec it will go to the adjustment mode. When I press longer it will start blinking for a few times only the red led. Then just stops. I can't seem to go on the pairing mode where both the green and red leds will blink. Also when I double press the button nothing happens. So I cannot even switch between shift modes.

What could be the problem here? TIA
You have the Shimano EW-WU111 BT unit installed ?
Steve B. is offline  
Old 03-11-21, 11:01 AM
  #3  
Junpogs
Newbie
Thread Starter
 
Join Date: Mar 2021
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Originally Posted by Steve B. View Post
You have the Shimano EW-WU111 BT unit installed ?

yes i do have the WU111 unit installed. I also have the bt-dn110 battery as well.
Junpogs is offline  
Old 03-11-21, 12:12 PM
  #4  
flanso 
Full Member
 
Join Date: May 2008
Location: Tampa
Posts: 295

Bikes: Gunnar Sport 105/UDi2, previous: Lambert, Giant FCR3, Cannondale Synapse Carbon 105, Specialized Roubaix SL4 Comp UDi2

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Likes: 0
Liked 7 Times in 5 Posts
Perhaps you would do well to temporarily disconnect the wireless module and connect your PC to the junction box. Then run the PC version of e-tube to establish whether your Di2 components are all recognized.
flanso is offline  
Old 03-11-21, 01:01 PM
  #5  
Iride01 
more daylight today!
 
Iride01's Avatar
 
Join Date: Jul 2017
Location: Mississippi
Posts: 12,195

Bikes: Tarmac Disc Comp Di2 - 2020

Mentioned: 43 Post(s)
Tagged: 0 Thread(s)
Quoted: 4995 Post(s)
Liked 3,502 Times in 2,429 Posts
Are you going by the instructions Shimano gives and are just confused by their presentation? Or are you just winging it?


You might find some things here that clear up some of things that are confusing you.... https://bettershifting.com/

Last edited by Iride01; 03-11-21 at 01:04 PM.
Iride01 is offline  
Likes For Iride01:
Old 03-11-21, 01:15 PM
  #6  
Junpogs
Newbie
Thread Starter
 
Join Date: Mar 2021
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Originally Posted by flanso View Post
Perhaps you would do well to temporarily disconnect the wireless module and connect your PC to the junction box. Then run the PC version of e-tube to establish whether your Di2 components are all recognized.
yes this would prolly my next course of action. Its just I have a Mac and the etube app is not supported. Might have to borrow someone else's pc for this. For the PC, do i just connect to it using the usb cable?
Junpogs is offline  
Old 03-11-21, 01:21 PM
  #7  
Junpogs
Newbie
Thread Starter
 
Join Date: Mar 2021
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Originally Posted by Iride01 View Post
Are you going by the instructions Shimano gives and are just confused by their presentation? Or are you just winging it?

yes i did. Only thing I get is the red led that turns to solid the blinks after. Double press doesn't do anything too.
Junpogs is offline  
Old 03-11-21, 01:36 PM
  #8  
Iride01 
more daylight today!
 
Iride01's Avatar
 
Join Date: Jul 2017
Location: Mississippi
Posts: 12,195

Bikes: Tarmac Disc Comp Di2 - 2020

Mentioned: 43 Post(s)
Tagged: 0 Thread(s)
Quoted: 4995 Post(s)
Liked 3,502 Times in 2,429 Posts
I don't really think there is a pairing mode for the wu111 itself. I think all you have to do is make sure the Di2 stuff isn't asleep. So just activate it by pushing a lever to shift or pressing the button on the on the bar end or your external box briefly. Then go through the pairing steps on your device you are wanting to pair with it.

On the other hand, if your Di2 stuff isn't set up and functioning in every other respect, then there isn't much point in trying to pair with it.

Unless maybe you are trying to use your phone app to set it up. Give up, use your PC and the supplied cable and sm-bcr2

Last edited by Iride01; 03-11-21 at 01:40 PM.
Iride01 is offline  
Old 03-11-21, 02:50 PM
  #9  
flanso 
Full Member
 
Join Date: May 2008
Location: Tampa
Posts: 295

Bikes: Gunnar Sport 105/UDi2, previous: Lambert, Giant FCR3, Cannondale Synapse Carbon 105, Specialized Roubaix SL4 Comp UDi2

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Likes: 0
Liked 7 Times in 5 Posts
Originally Posted by Junpogs View Post
yes this would prolly my next course of action. Its just I have a Mac and the etube app is not supported. Might have to borrow someone else's pc for this. For the PC, do i just connect to it using the usb cable?
Yes, it connects to the PC with the USB cable used for charging the Di2. When connected to the bike, the E-tube lists all of the Di2 components that it "sees." That might be a good first step in analyzing your problem. It is amazing that Shimano can't develop software for Mac.
flanso is offline  
Old 03-11-21, 02:57 PM
  #10  
Iride01 
more daylight today!
 
Iride01's Avatar
 
Join Date: Jul 2017
Location: Mississippi
Posts: 12,195

Bikes: Tarmac Disc Comp Di2 - 2020

Mentioned: 43 Post(s)
Tagged: 0 Thread(s)
Quoted: 4995 Post(s)
Liked 3,502 Times in 2,429 Posts
You might also be surprised what little a shop might charge you for setting it up if there isn't any mistakes they have to correct.
Iride01 is offline  
Old 03-12-21, 10:09 AM
  #11  
cxwrench
Senior Member
 
cxwrench's Avatar
 
Join Date: Jul 2013
Location: Nor-Cal
Posts: 3,767

Bikes: lots

Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 1953 Post(s)
Liked 2,923 Times in 1,487 Posts
The blinking red LED that comes after the solid red 'adjustment mode' is recovery mode. You have to be turning the crank while the it's blinking. Turn the crank til it shifts through all gears and the LED goes out. If you just hold the button for a second or two and are in adjustment mode, then hold for another second to exit this mode both of the LEDs will light up and tell you which shift mode you're in.
cxwrench is offline  
Likes For cxwrench:
Old 03-12-21, 12:54 PM
  #12  
flanso 
Full Member
 
Join Date: May 2008
Location: Tampa
Posts: 295

Bikes: Gunnar Sport 105/UDi2, previous: Lambert, Giant FCR3, Cannondale Synapse Carbon 105, Specialized Roubaix SL4 Comp UDi2

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Likes: 0
Liked 7 Times in 5 Posts
This guy explains how to run E-Tube on a Mac:
https://bettershifting.com/run-di2-e...g-virtual-box/
flanso is offline  
Old 03-12-21, 11:01 PM
  #13  
jaxgtr
Senior Member
 
jaxgtr's Avatar
 
Join Date: Jul 2006
Location: Jacksonville, FL
Posts: 6,009

Bikes: Trek Domane SLR 7 eTap AXS, Trek Emonda ALR 6, Trek FX 5 Sport

Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 475 Post(s)
Liked 986 Times in 594 Posts
Originally Posted by flanso View Post
This guy explains how to run E-Tube on a Mac:
https://bettershifting.com/run-di2-e...g-virtual-box/
Virtual Box is a fantastic program....been using it for over 10 years.
__________________
Brian | 2023 Trek Domane SLR 7 eTap AXS | 2016 Trek Emonda ALR 6 | 2022 Trek FX Sport 5
Originally Posted by AEO View Post
you should learn to embrace change, and mock it's failings every step of the way.











jaxgtr is offline  
Old 03-15-21, 02:21 AM
  #14  
TerryDi2C
Di2 fanatic
 
TerryDi2C's Avatar
 
Join Date: Aug 2019
Location: The Netherlands
Posts: 132
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 49 Post(s)
Liked 57 Times in 36 Posts
Yeah.. GPLama has a pretty nice video on that .

I think I would try to connect it to a PC (or in your case, mac) and then (1) update all firmware that needs to be updated and (2) make sure it actually sees the EW-WU111.
Also, use E-Tube Project 3.4.5 if you can - version 4 is very buggy and doesn't work half of the time (if you're using the charger.. using the SM-PCE1 / 02 is fine).
TerryDi2C is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.