Go Back  Bike Forums > Bike Forums > Classic & Vintage
Reload this Page >

Has anyone applied new Paramount decals?

Classic & Vintage This forum is to discuss the many aspects of classic and vintage bicycles, including musclebikes, lightweights, middleweights, hi-wheelers, bone-shakers, safety bikes and much more.

Has anyone applied new Paramount decals?

Old 05-10-06, 04:42 PM
  #1  
Kingofbeers
I really like bikes
Thread Starter
 
Kingofbeers's Avatar
 
Join Date: Jul 2003
Location: Crestone, Colorado
Posts: 71

Bikes: Paramounts! - '65, '71, '74, '83, '98, '48 Schwinn Continental, '01 Homegrown Factory, Longbikes Tandem, '98 Trek Y-Foil

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Has anyone applied new Paramount decals?

I'd sure appreciate some pointers, especially on applying the seatmast decal and getting the carrier sheet removed. I've got a second set ordered from Waterford for a '65 chrome Paramount, and I'd like things to go a little better than they did with the first set.

It seems like the backing on these decals is almost impossible to remove without ruining everything. I've put new decals on other bikes without many problems, so I'm sure I'm missing a step somewhere with these.

Any tips would be most welcome -

Thanks
__________________
Schwinn Paramounts - 1965, '71, '74, 83
Match Paramounts - '98, '99
1948 Schwinn Continental
1978 Medici Pro Strada
1990 Cannondale ST 600
1998 Trek Y-Foil
1999 Schwinn Homegrown MTB
2000 Schwinn Homegrown MTB
1999 Longbikes Tandem
Kingofbeers is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
refthimos
Track Cycling: Velodrome Racing and Training Area
56
04-20-13 06:54 PM
skinnyguy
Road Cycling
4
01-22-11 09:40 PM
John E
Classic & Vintage
10
06-19-08 12:49 AM
sexyluigi21
Bicycle Mechanics
5
05-03-07 10:15 PM
Apollo
Road Cycling
5
04-11-06 08:03 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.