Go Back  Bike Forums > Bike Forums > Electric Bikes
Reload this Page >

Shimano steps display frozen?

Notices
Electric Bikes Here's a place to discuss ebikes, from home grown to high-tech.

Shimano steps display frozen?

Old 06-15-19, 06:27 AM
  #1  
Jordigas00
Newbie
Thread Starter
 
Join Date: Jun 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Shimano steps display frozen?

Hi, Iím having an issue with my new YT Decoy e-bike, the shimano steps display is frozen, I canít turn bike on or off. I have disconnected the battery, plugged out the display leads. Any suggestions of what to try next?
Jordigas00 is offline  
Old 06-15-19, 09:58 AM
  #2  
01 CAt Man Do
Senior Member
 
01 CAt Man Do's Avatar
 
Join Date: Dec 2012
Location: Columbia, Maryland
Posts: 1,119

Bikes: Mountain bike & Hybrid tour bike

Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 178 Post(s)
Liked 6 Times in 5 Posts
Originally Posted by Jordigas00 View Post
Hi, Iím having an issue with my new YT Decoy e-bike, the shimano steps display is frozen, I canít turn bike on or off. I have disconnected the battery, plugged out the display leads. Any suggestions of what to try next?
If you disconnected the battery then reconnected and the control module didn't reboot I'd take it back to the dealer. Could be a problem with the software or firmware within the control module. If that's so the dealer should be able to update the program or reprogram. Shouldn't take more than 10-15 minutes. BTW, that is one nice looking bike. Wish I had that kind of bucks. Anyway worst case scenario is you have a bad control module that might have to be replaced. I say that because disconnecting/reconnecting should of rebooted the module. If it's still frozen after removing power...ehh...that's not a good sign.
01 CAt Man Do is offline  
Old 12-09-19, 03:16 PM
  #3  
Amoslee
Newbie
 
Join Date: Dec 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Did you ever figure out what happened to your bike?

I'm also having the same problem with my decoy
Amoslee is offline  
Old 12-16-19, 12:32 PM
  #4  
01 CAt Man Do
Senior Member
 
01 CAt Man Do's Avatar
 
Join Date: Dec 2012
Location: Columbia, Maryland
Posts: 1,119

Bikes: Mountain bike & Hybrid tour bike

Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 178 Post(s)
Liked 6 Times in 5 Posts
Originally Posted by Amoslee View Post
I'm also having the same problem with my decoy
If you noticed the person who started the thread only posted one time. They have not posted since. I would suggest you do what I told the other person to do. If you're lucky it will only be an issue where the software needs to be updated. The dealer that sold you the bike can usually do this in about 10 minutes or so.
01 CAt Man Do is offline  
Old 03-11-20, 12:22 PM
  #5  
CEOJ
Newbie
 
Join Date: Mar 2020
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 1 Time in 1 Post
Did either of you guys get to the bottom of the situation? Mine has the exact same issue, really dont want to have to ship it back to Germany, especially given the current Coronavirus issue..
Cheers
CEOJ is offline  
Old 03-16-20, 09:20 AM
  #6  
01 CAt Man Do
Senior Member
 
01 CAt Man Do's Avatar
 
Join Date: Dec 2012
Location: Columbia, Maryland
Posts: 1,119

Bikes: Mountain bike & Hybrid tour bike

Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 178 Post(s)
Liked 6 Times in 5 Posts
Originally Posted by CEOJ View Post
Did either of you guys get to the bottom of the situation? Mine has the exact same issue, really dont want to have to ship it back to Germany, especially given the current Coronavirus issue..
Cheers
I think the best thing to do would be to call a couple LBS near you and ask if they can reprogram a Shimano Steps module for your particular ebike. Shouldn't matter if they don't sell the same bike. They just have to download the correct Steps program from the Shimano website for your bike and then upload the new program to your module. Try a Trek dealer. That's where I bought my bike and had my module reprogramed.
01 CAt Man Do is offline  
Old 04-09-20, 12:33 AM
  #7  
Dave1969
Newbie
 
Join Date: Apr 2020
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Originally Posted by CEOJ View Post
Did either of you guys get to the bottom of the situation? Mine has the exact same issue, really dont want to have to ship it back to Germany, especially given the current Coronavirus issue..
Cheers
did you manage to fix your decoy. Having exactly same problem. The bike is bone dry and was stored inside overnight. Tried the usual contact cleaner on terminals but nothing is working. It's a very poor design as drying terminals is something I need to do after every wash
Dave1969 is offline  
Old 04-09-20, 03:32 PM
  #8  
CEOJ
Newbie
 
Join Date: Mar 2020
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 1 Time in 1 Post
Originally Posted by Dave1969 View Post
did you manage to fix your decoy. Having exactly same problem. The bike is bone dry and was stored inside overnight. Tried the usual contact cleaner on terminals but nothing is working. It's a very poor design as drying terminals is something I need to do after every wash
Yea I got it fixed by taking it to a Shimano steps service center where they effectively rebooted everythung. It's essentially and issue with a non-shimano battery talking to a Shimano system. Cost me 50 quid or so, much cheaper than sending back to Germany, and hasn't happened again since. HOWEVER, the mechanic who fixed it for me told me he'd been seeing me again as this issue happens a lot! Haven't contacted YT as they absolutely won't reimburse me, and having someone else work on the bike, even a steps centre, will no doubt void their warranty. Insanely frustrating.

Looking back on it, mine occured after the second time I cleaned it. I had the bike upside down and I won't be doing that again, could be that gravity took the water somewhere sinister.

Best of luck.
CEOJ is offline  
Likes For CEOJ:
Old 04-20-20, 08:05 AM
  #9  
CEOJ
Newbie
 
Join Date: Mar 2020
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 1 Time in 1 Post
The damn thing broke again. Washed with damp cloth, no where near a hose and it's still gone. Fuming.
Am hoping YT will refund me, for the three months I have owned this bike it has been trouble-free for about a fortnight total.
Dipped my two in direct to consumer pool and will not be doing it again.
CEOJ is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bartel.michiels
Electric Bikes
5
10-11-19 07:35 AM
Kbri
Electric Bikes
4
03-31-19 02:32 AM
ebttasturias
Electric Bikes
1
01-12-19 09:26 PM
Leon223
Road Cycling
1
06-18-17 11:38 AM
Aliante
Electric Bikes
6
02-07-16 11:16 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.