Go Back  Bike Forums > Bike Forums > Electric Bikes
Reload this Page >

Giant Lafree twist dx charger blinking

Notices
Electric Bikes Here's a place to discuss ebikes, from home grown to high-tech.

Giant Lafree twist dx charger blinking

Old 11-11-19, 09:11 PM
  #1  
meb
Senior Member
Thread Starter
 
meb's Avatar
 
Join Date: Aug 2003
Location: arlington, VA
Posts: 1,764
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Likes: 0
Liked 5 Times in 4 Posts
Giant Lafree twist dx charger blinking

The charger was working one night ago.
Tonight the led is blinking. About a period of 2 sec, 1 sec on 1 sec off.
The charger dos not appear to be bringing the battery up after about 2 hours on the battery pack premised upon the charge indicator.
The light does not blink when plug into AC but not attached to the battery nor when attached to the battery but not AC.
Anyone know if this is a problem with the charger or battery?
Any specific knowledge of what the malfunction is?
Haven't yet checked the charger nor battery with a voltmeter, though the on bike charge level is showing a single of the 5 leds.
meb is offline  
Old 11-12-19, 11:41 PM
  #2  
momsonherbike
Senior Member
 
momsonherbike's Avatar
 
Join Date: Nov 2012
Location: USA
Posts: 307

Bikes: All mine are electric bikes now

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 57 Post(s)
Liked 58 Times in 36 Posts
Sounds like the charger problem/ malfunction to me.

Does your bike shop have a charger you could try out if you brought your bike to the shop? That would demonstrate very quickly which is at fault - charger or battery.
momsonherbike is offline  
Old 11-13-19, 10:56 AM
  #3  
meb
Senior Member
Thread Starter
 
meb's Avatar
 
Join Date: Aug 2003
Location: arlington, VA
Posts: 1,764
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Likes: 0
Liked 5 Times in 4 Posts
The ground wire inside the metal charging port connector came loose and I suspect the wire may have shorted blowing a fuse inside the charger.

There are zero volts between the red and black wires, so likely a fuse. I previously got voltage outputs of 29 volts when there was no battery load, so it isn't just a smart charger sensing whether there is a battery present.
meb is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.