Go Back  Bike Forums > Bike Forums > Electronics, Lighting, & Gadgets
Reload this Page >

Garmin speed and cadence sensor calibration

Notices
Electronics, Lighting, & Gadgets HRM, GPS, MP3, HID. Whether it's got an acronym or not, here's where you'll find discussions on all sorts of tools, toys and gadgets.

Garmin speed and cadence sensor calibration

Old 07-02-16, 06:00 PM
  #1  
turkey9186
Senior Member
Thread Starter
 
Join Date: Oct 2004
Location: CA SF Bay Area
Posts: 476

Bikes: 2014 CDale EVO, 2007 System Six, 2004 Litespeed Solano, 2002 Burley Duet

Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 92 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Garmin speed and cadence sensor calibration

I picked up a used Garmin soeed and cadence sensor and installed it on a new bike build. Both the cadence and speed read 3 times what they should. (20 MPH speed shows as 60 and a 60 rpm cadence at 180) I tried it on another bike and with both my 1000 and older 705 with the same results. Any ideas on what could be wrong?
turkey9186 is offline  
Old 07-02-16, 06:16 PM
  #2  
John_V 
Senior Member
 
John_V's Avatar
 
Join Date: Jun 2011
Location: Tampa, Florida
Posts: 5,507

Bikes: 2017 Colnago C-RS, 2012 Colnago Ace, 2010 Giant Cypress hybrid

Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 379 Post(s)
Liked 68 Times in 52 Posts
AFAIK, there are no calibration settings on speed/cadence sensors. You can try resetting the sensor by removing the battery, flipping it over and installing it with reverse polarity for about three seconds. If that doesn't clear the problem, then you may have a bad sensor.
__________________
HCFR Cycling Team
Ride Safe ... Ride Hard ... Ride Daily

2017 Colnago C-RS
2012 Colnago Ace
2010 Giant Cypress
John_V is offline  
Old 07-02-16, 07:44 PM
  #3  
rm -rf
don't try this at home.
 
rm -rf's Avatar
 
Join Date: Jan 2006
Location: N. KY
Posts: 5,185
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 672 Post(s)
Liked 55 Times in 44 Posts
The sensor has a small white button for testing. Click it, and the LED on the body lights up for each pedal revolution and each spoke magnet trigger. (One red and one green light.)

Are you using the stock Garmin magnets?

That's interesting that the cadence is tripled too. I could see a speed error if the wheel size was wrong.

Could try this, but you've probably done it already:
On the 705, go to Settings --> Ant+Sport --> Accessories -->Cadence sensor present? --> Restart Scan

Spin the wheel. after about 5-10 seconds, it'll pop up a message that it found the sensor.
rm -rf is offline  
Old 07-03-16, 09:34 PM
  #4  
turkey9186
Senior Member
Thread Starter
 
Join Date: Oct 2004
Location: CA SF Bay Area
Posts: 476

Bikes: 2014 CDale EVO, 2007 System Six, 2004 Litespeed Solano, 2002 Burley Duet

Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 92 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
I will try the battery trick. It is doing it with two different sets of magnets on two different bikes, and with both a 705 and a 1000. Probably a bad sensor...
I did have a couple of great Strava KOMs until I deleted them though!
turkey9186 is offline  
Old 07-03-16, 09:46 PM
  #5  
Marcus_Ti 
FLIR Kitten to 0.05C
 
Marcus_Ti's Avatar
 
Join Date: Sep 2014
Location: Lincoln, Nebraska
Posts: 5,126

Bikes: Roadie: Seven Axiom Race Ti w/Chorus 11s. CX/Adventure: Carver Gravel Grinder w/ Di2

Mentioned: 29 Post(s)
Tagged: 0 Thread(s)
Quoted: 2228 Post(s)
Liked 250 Times in 159 Posts
The wheel speed sensor counts wheel revolutions and then uses a firm-set wheel circumference to display speed. Check the wheel diameter in the head unit. But odds are you have some dud sensors if cadence is doing it too.
Marcus_Ti is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
baffle
Training & Nutrition
1
03-18-17 02:37 PM
taat2d
General Cycling Discussion
10
07-02-16 09:39 AM
TCR Rider
Bicycle Mechanics
4
06-12-15 08:08 PM
Dannydyn
Electronics, Lighting, & Gadgets
2
04-28-13 10:24 AM
sirious94
Road Cycling
5
06-07-10 09:59 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.