Go Back  Bike Forums > Bike Forums > Electronics, Lighting, & Gadgets
Reload this Page >

Garmin Edge 530 turn by turn announcements

Notices
Electronics, Lighting, & Gadgets HRM, GPS, MP3, HID. Whether it's got an acronym or not, here's where you'll find discussions on all sorts of tools, toys and gadgets.

Garmin Edge 530 turn by turn announcements

Old 06-27-22, 09:38 AM
  #1  
Andrey
Senior Guest
Thread Starter
 
Andrey's Avatar
 
Join Date: Jan 2008
Location: Upstate NY, USA
Posts: 360

Bikes: Many

Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Liked 32 Times in 25 Posts
Question Garmin Edge 530 turn by turn announcements

My Edge 530 does not "say", "announce" turn- by-turn navigation. It is paired to my phone(Google Pixel 4a) that has Garmin Connect installed on it. Phone is paired to my headphones and all the connections are fine. Under "activity options" navigation alerts are "on" .

I only got it to work once when testing a route. And in order for it to work that time I had to "reset" the 530 completely and it only worked one time. Tried it again yesterday and it does not work again, although all setting are correct.

It shows maps and directions and the head unit "beeps" to prompt me before the turns, so it is navigating, but the phone does not "announce" street names. Any help is appreciated. Thanks.

Last edited by Andrey; 06-27-22 at 12:01 PM.
Andrey is offline  
Old 06-27-22, 12:24 PM
  #2  
njkayaker
Senior Member
 
Join Date: Sep 2007
Posts: 13,328
Mentioned: 27 Post(s)
Tagged: 0 Thread(s)
Quoted: 3534 Post(s)
Liked 938 Times in 653 Posts
Is Garmin Connect running on the phone?
njkayaker is online now  
Old 06-27-22, 12:36 PM
  #3  
Andrey
Senior Guest
Thread Starter
 
Andrey's Avatar
 
Join Date: Jan 2008
Location: Upstate NY, USA
Posts: 360

Bikes: Many

Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Liked 32 Times in 25 Posts
Originally Posted by njkayaker View Post
Is Garmin Connect running on the phone?
The app is open on the phone and it is connected to the Edge 530.
Andrey is offline  
Old 06-27-22, 01:05 PM
  #4  
njkayaker
Senior Member
 
Join Date: Sep 2007
Posts: 13,328
Mentioned: 27 Post(s)
Tagged: 0 Thread(s)
Quoted: 3534 Post(s)
Liked 938 Times in 653 Posts
Originally Posted by Andrey View Post
The app is open on the phone and it is connected to the Edge 530.
It has to be running (not necessarily visible).

From what you describe, it should be working.

There's nothing on the device that needs to be set.

Is "turn guidance" (the big white arrows) enabled?

Last edited by njkayaker; 06-27-22 at 01:11 PM.
njkayaker is online now  
Old 06-27-22, 01:22 PM
  #5  
Andrey
Senior Guest
Thread Starter
 
Andrey's Avatar
 
Join Date: Jan 2008
Location: Upstate NY, USA
Posts: 360

Bikes: Many

Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Liked 32 Times in 25 Posts
Originally Posted by njkayaker View Post
It has to be running (not necessarily visible).

From what you describe, it should be working.

There's nothing on the device that needs to be set.

Is "turn guidance" (the big white arrows) enabled?
Thank you.
How do I know if it is running?
I opened the app, within a few seconds it finds the Edge and connects to it. In Garmin Connect on the phone from the menu I choose Garmin devices, it shows the Edge 530 connected to the phone. Under "Activity Options", I click "Audio Prompts", it snows "lap alerts" and "Navigation Alerts" are "on"( both blue squares, now white arrows). When I open the app and the Edge 530 is on, the phone is syncing it automatically. Does it mean it is "on"?
Andrey is offline  
Old 06-27-22, 01:28 PM
  #6  
njkayaker
Senior Member
 
Join Date: Sep 2007
Posts: 13,328
Mentioned: 27 Post(s)
Tagged: 0 Thread(s)
Quoted: 3534 Post(s)
Liked 938 Times in 653 Posts
Originally Posted by Andrey View Post
How do I know if it is running?
You'll see the big white arrows pop-up or on the map.

"Turn guidance" is a setting on the 530.

"Turn guidance" is enabled in the submenu of the "saved courses" list.

(I don't have a 530 but it should work similarly to what I have.)

Originally Posted by Andrey View Post
I opened the app, within a few seconds it finds the Edge and connects to it. In Garmin Connect on the phone from the menu I choose Garmin devices, it shows the Edge 530 connected to the phone. Under "Activity Options", I click "Audio Prompts", it snows "lap alerts" and "Navigation Alerts" are "on"( both blue squares, now white arrows). When I open the app and the Edge 530 is on, the phone is syncing it automatically. Does it mean it is "on"?
The "lap alert" setting isn't relevant. The "navigation alerts" needs do be enabled on Garmin Connect Mobile (as you say is the case).
njkayaker is online now  
Old 06-27-22, 01:32 PM
  #7  
Andrey
Senior Guest
Thread Starter
 
Andrey's Avatar
 
Join Date: Jan 2008
Location: Upstate NY, USA
Posts: 360

Bikes: Many

Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Liked 32 Times in 25 Posts
Originally Posted by njkayaker View Post
You'll see the big white arrows pop-up or on the map.

"Turn guidance" is a setting on the 530.

"Turn guidance" is enabled in the submenu of the "saved courses" list.

(I don't have a 530 but it should work similarly to what I have.)


.
The "turn guidance" is enabled on the Edge. The edge is navigating the course when I m riding, beeps and shows the turns, but the Garmin Connect does not "announce" street names. I m not sure why...running out of options.
Andrey is offline  
Old 06-27-22, 01:36 PM
  #8  
njkayaker
Senior Member
 
Join Date: Sep 2007
Posts: 13,328
Mentioned: 27 Post(s)
Tagged: 0 Thread(s)
Quoted: 3534 Post(s)
Liked 938 Times in 653 Posts
Originally Posted by Andrey View Post
The "turn guidance" is enabled on the Edge. The edge is navigating the course when I m riding, beeps and shows the turns, but the Garmin Connect does not "announce" street names. I m not sure why...running out of options.
Maybe, try turning BT on the phone off and on. I don't have much for you at this point.
njkayaker is online now  
Old 06-27-22, 01:48 PM
  #9  
Andrey
Senior Guest
Thread Starter
 
Andrey's Avatar
 
Join Date: Jan 2008
Location: Upstate NY, USA
Posts: 360

Bikes: Many

Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Liked 32 Times in 25 Posts
Originally Posted by njkayaker View Post
Maybe, try turning BT on the phone off and on. I don't have much for you at this point.
Tried that Thank you anyway.
Andrey is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.