Go Back  Bike Forums > Bike Forums > Electronics, Lighting, & Gadgets
Reload this Page >

New Garmin Edge 840 USB-C recharging?

Notices
Electronics, Lighting, & Gadgets HRM, GPS, MP3, HID. Whether it's got an acronym or not, here's where you'll find discussions on all sorts of tools, toys and gadgets.

New Garmin Edge 840 USB-C recharging?

Old 06-15-24, 04:28 PM
  #1  
ignominious poltroon
Thread Starter
 
Polaris OBark's Avatar
 
Join Date: Jan 2022
Posts: 4,326
Liked 3,700 Times in 1,933 Posts
New Garmin Edge 840 USB-C recharging?

I just put my new Garmin Edge 840 on my Apple 65W USB-C charger to recharge. It turns off at 80%. Is that expected behavior? (I could see how that might be the case, if the idea is to maximize battery lifetime.) [This turned out to be a red herring.]

When I first got it two days ago, I used a USB-A to C cable connected to an old iMac, while I loaded it up with additional maps and stuff, and it charged at least to about 98% IIRC.

My previous (all non-USB-C) Garmin devices charge to 100%, including my watch, using an adaptor that connects to the same above-referenced Apple charger and cable.

Last edited by Polaris OBark; 06-18-24 at 11:08 AM.
Polaris OBark is offline  
Old 06-15-24, 05:11 PM
  #2  
ignominious poltroon
Thread Starter
 
Polaris OBark's Avatar
 
Join Date: Jan 2022
Posts: 4,326
Liked 3,700 Times in 1,933 Posts
Never mind. luser error I think.
Polaris OBark is offline  
Old 06-18-24, 10:09 AM
  #3  
Randomhead
 
Join Date: Aug 2008
Location: Happy Valley, Pennsylvania
Posts: 24,734
Liked 3,932 Times in 2,681 Posts
What was the problem? I was somewhat disappointed that the 830 had a micro, but I guess that's better than the mini that the 800 had. Or do I have mini and micro backwards.
unterhausen is offline  
Likes For unterhausen:
Old 06-18-24, 10:29 AM
  #4  
ignominious poltroon
Thread Starter
 
Polaris OBark's Avatar
 
Join Date: Jan 2022
Posts: 4,326
Liked 3,700 Times in 1,933 Posts
The *30 has micro-usb. The *40 has USB-C, which I regard as a distinct improvement.

What I think is happening is that I have to turn on (or leave on) the Garmin 840, and then plug in to USB, to get it to charge; it then automatically goes into charging mode. (I suspect this order of operations has something to do with its ability to use an external power supply while riding, but that it just speculation on my part.)

In any case, there is nothing wrong with my 840, as far as I can tell.

Feel free to delete this thread if you want to.
Polaris OBark is offline  
Old 06-27-24, 06:01 PM
  #5  
Senior Member
 
biker128pedal's Avatar
 
Join Date: Jan 2007
Location: Eastern VA
Posts: 1,776

Bikes: 2022 Fuel EX 8, 2021 Domane SL6, Black Beta (Nashbar frame), 2004 Trek 1000C for the trainer

Liked 518 Times in 287 Posts
I have a 1040 solar. It charges fine on the PC but turns on to charge mode when plugged in. But funny when I plugged it into a portable battery to charge I had to manually turn it on for it to charge. Your MAC may be similar.
biker128pedal is offline  
Old 06-27-24, 09:35 PM
  #6  
Randomhead
 
Join Date: Aug 2008
Location: Happy Valley, Pennsylvania
Posts: 24,734
Liked 3,932 Times in 2,681 Posts
OP fixed his problem and asked me to delete. But I didn't, because I though others might have the same issue. Don't make me listen to him.
unterhausen is offline  
Old 07-08-24, 03:24 PM
  #7  
ignominious poltroon
Thread Starter
 
Polaris OBark's Avatar
 
Join Date: Jan 2022
Posts: 4,326
Liked 3,700 Times in 1,933 Posts
Originally Posted by unterhausen
Don't make me listen to him.
Somehow my wife seems to have hijacked unterhausen's account.

Polaris OBark is offline  
Likes For Polaris OBark:
Old 07-08-24, 03:36 PM
  #8  
ignominious poltroon
Thread Starter
 
Polaris OBark's Avatar
 
Join Date: Jan 2022
Posts: 4,326
Liked 3,700 Times in 1,933 Posts
The way recharging is working for me (independent of USB power source) is this:

When my Edge 840 is powered off, I plug it into a USB-C cable attached to a charger/power source. The 840 then boots into bike ride mode, and if I pull out the USB-C cable, it says something like "external power source disconnected." Keeping the cable plugged in, I can power it down. As it shuts down, it then goes into charging mode, and completes the charge to 98% or more.

(The way my 530 worked was from a powered down state, I could plug it into a charger via micro-USB. It would immediately go into charging mode.)

Last edited by Polaris OBark; 07-11-24 at 12:11 PM. Reason: clarity
Polaris OBark is offline  
Old 07-08-24, 03:41 PM
  #9  
Randomhead
 
Join Date: Aug 2008
Location: Happy Valley, Pennsylvania
Posts: 24,734
Liked 3,932 Times in 2,681 Posts
I have seen my 830 go into ride mode when I plug it in. But not always. Reminds me I need to recharge it.
unterhausen is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Your Privacy Choices -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.