Go Back  Bike Forums > Bike Forums > Electronics, Lighting, & Gadgets
Reload this Page >

flighdeck problem - speed, distance, time disappeared

Notices
Electronics, Lighting, & Gadgets HRM, GPS, MP3, HID. Whether it's got an acronym or not, here's where you'll find discussions on all sorts of tools, toys and gadgets.

flighdeck problem - speed, distance, time disappeared

Old 10-13-08, 10:14 AM
  #1  
spiritrider
Member
Thread Starter
 
Join Date: Jun 2008
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
flighdeck problem - speed, distance, time disappeared

I have had my Shimano Flightdeck for a LONG time and love it, but recently it has begun acting up. The gear display and vel/rpm still work, but time, distance, avg speed no longer display. I replaced the battery recently and all seemed to work well, till about a week ago, when it failed during a long-distance race, when it was important to know my distance and time. Any solutions???
spiritrider is offline  
Old 10-13-08, 04:49 PM
  #2  
GTALuigi
Senior Member
 
GTALuigi's Avatar
 
Join Date: Sep 2008
Location: GTA
Posts: 764

Bikes: Dahon Mu SL 08 / Matrix 08

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
get a new one?

did it get wet or damaged in anyway?

if you want something that works for sure, definitely get a new one.
else you can try to send it in for a repair.
GTALuigi is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.