Bike Forums

Bike Forums (
-   Electronics, Lighting, & Gadgets (
-   -   Dead Garmin Edge 305 (

bernmart 03-22-09 08:21 AM

Dead Garmin Edge 305
I've been using my 305 with great satisfaction for almost two years (the cadence sensor quit several months ago, but that's a different story). So after Friday's ride I downloaded the data to my computer, charged it fully, and put it back on the bike.

Yesterday AM I set out on a long ride, but the Garmin wouldn't turn on! Hasn't turned on since, and when hooked up to the charger there's no screen display of any kind. It's suddenly and without warning dead as a doornail.

What's to be done, if anything? It's surely out of warranty, and I can't contact Garmin by phone until Monday AM.

rodrigaj 03-22-09 09:49 AM

Press the two halves together while trying to turn it on. If it turns on, you have the well documented press fit battery connection problem. Usually the turning-off will happen when you are riding. Initially once in a while then more often. Call Garmin. They will offer you a refurbished unit for about $100.

The problem stems from the way the unit is put together. The two halves are glued together, and there is a spring press connection to the battery that loosens over time. They corrected this problem in the Garmin 705, since the two halves are screwed together.

bernmart 03-22-09 10:39 AM

I tried it, and it's just as you said. I'll call them asap. Thanks, rodrigaj.

SSSTANG 04-06-09 01:01 PM


Originally Posted by bernmart (Post 8576239)
I tried it, and it's just as you said. I'll call them asap. Thanks, rodrigaj.

What did Garmin have to say? It seems I may have he same problem.

bernmart 04-06-09 01:28 PM

Via e-mail, at least, Garmin recommended a complete reset. I couldn't get it to reset. But, after pressing the two halves together and starting it several times, it's been working perfectly. So I'll wait for the next recurrence of the problem before contacting Garmin again.

The unit's well past warranty, so there doesn't seem to be much point in pressing the matter while the unit's working OK. Or maybe I'm just a wimp. Or both.

I hope this is some help.

All times are GMT -6. The time now is 02:25 AM.