Go Back  Bike Forums > Community Connections > Introductions
Reload this Page >

Help with E plus bike circa 2009(?)

Notices
Introductions Welcome to the BikeForums community! Please introduce yourself to other forum members here.

Help with E plus bike circa 2009(?)

Old 04-01-16, 01:57 PM
  #1  
Jpouridas
Newbie
Thread Starter
 
Join Date: Apr 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
Help with E plus bike circa 2009(?)

Yes the now defunct company.
I have a never used "sleeping" giant.
32v 1000w front hub battery to rear wheel motor. I want desperately to get this thing on the road. It has no charge, and no readout. Anyone with any insight, please help. Thanks!
Jpouridas is offline  
Old 04-01-16, 02:14 PM
  #2  
obed7
Senior Member
 
obed7's Avatar
 
Join Date: Jan 2015
Location: Porter, Texas
Posts: 4,125

Bikes: Trek Domane 5.2, Ridley Xfire, Giant Propel, KHS AeroComp

Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 1648 Post(s)
Likes: 0
Liked 1 Time in 1 Post
This is the intro section. You will not get any responses here. Post your issue in the appropriate section of the forum and you will have a better chance of finding someone who knows something about it.
obed7 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.