Go Back  Bike Forums > Bike Forums > Road Cycling
Reload this Page >

Powertap SL+ hub question

Notices
Road Cycling “It is by riding a bicycle that you learn the contours of a country best, since you have to sweat up the hills and coast down them. Thus you remember them as they actually are, while in a motor car only a high hill impresses you, and you have no such accurate remembrance of country you have driven through as you gain by riding a bicycle.” -- Ernest Hemingway

Powertap SL+ hub question

Old 06-09-20, 10:41 AM
  #1  
woodcraft
Senior Member
Thread Starter
 
woodcraft's Avatar
 
Join Date: Apr 2012
Location: Nor Cal
Posts: 6,016
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Quoted: 1814 Post(s)
Likes: 0
Liked 919 Times in 567 Posts
Powertap SL+ hub question

This has languished in electronics section, so trying it here...


I'm looking at setting up a PM for 2nd bike, & to check values of the crank-based on main bike.

Running 10 speed, tubular.

So does the SL+ hub work with Garmin/ Wahoo or not?

Online store: "With the flexibility of ANT+ Sport, all Plus-series PowerTaps can be paired with any ANT+Sport device. ANT+ guarantees seamless digital wireless communication, long battery life and communication reliability."


Ebay seller: "The CycleOps Powertap SL+ hub is an great solution for those craving more metrics on their rides and training plans. The PowerTap SL 2.4+ is completely wrieless, and displays power, torque, speed, cadence and heart rate to an external head unit. Is not compatible with Garmin or Wahoo GPS computers. WIll only work with the CycleOps PowerTap Head Unit."

ANT+ site seems to say yes.

Wiggle: With the flexibility of ANT+Sport, all Plus-series PowerTaps can be paired with any ANT+Sport device. So, either use the PowerTap CPU or other ANT+Sport compatible device.

Thanks
woodcraft is offline  
Old 06-09-20, 10:44 PM
  #2  
woodcraft
Senior Member
Thread Starter
 
woodcraft's Avatar
 
Join Date: Apr 2012
Location: Nor Cal
Posts: 6,016
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Quoted: 1814 Post(s)
Likes: 0
Liked 919 Times in 567 Posts
~100 views, no feedback.
woodcraft is offline  
Old 06-10-20, 07:45 AM
  #3  
noodle soup
Senior Member
 
noodle soup's Avatar
 
Join Date: Nov 2015
Posts: 8,910
Mentioned: 20 Post(s)
Tagged: 0 Thread(s)
Quoted: 4694 Post(s)
Liked 1,860 Times in 991 Posts
Originally Posted by woodcraft View Post
~100 views, no feedback.
It's supposed to work, but there probably aren't many people here that still use that hub.
noodle soup is offline  
Old 06-10-20, 09:13 AM
  #4  
RChung
Perceptual Dullard
 
Join Date: Sep 2009
Posts: 1,990
Mentioned: 33 Post(s)
Tagged: 0 Thread(s)
Quoted: 628 Post(s)
Liked 662 Times in 272 Posts
The PT SL+ hub was the revision to make sure it worked with standard ANT+ devices. The "+" is essential: the non-plus SL model would work ONLY with Power Tap's own head unit. Make sure it's a "+" model.

The SL+ was a 2nd generation model. The current PT hubs are 3rd gen, and have better bearings than the G2. You can often find used G3 models pretty cheap--in January, a guy I know bought a used G3 hub mounted in a 28-spoke rim (okay but not great, and needed a little truing) with a still usable tire for $225. It was local so we were able to check it out to verify that it was working.

Last edited by RChung; 06-10-20 at 09:22 AM.
RChung is offline  
Likes For RChung:
Old 06-10-20, 09:37 AM
  #5  
woodcraft
Senior Member
Thread Starter
 
woodcraft's Avatar
 
Join Date: Apr 2012
Location: Nor Cal
Posts: 6,016
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Quoted: 1814 Post(s)
Likes: 0
Liked 919 Times in 567 Posts
Thanks!
woodcraft is offline  
Old 06-10-20, 10:07 AM
  #6  
noodle soup
Senior Member
 
noodle soup's Avatar
 
Join Date: Nov 2015
Posts: 8,910
Mentioned: 20 Post(s)
Tagged: 0 Thread(s)
Quoted: 4694 Post(s)
Liked 1,860 Times in 991 Posts
Originally Posted by RChung View Post
The PT SL+ hub was the revision to make sure it worked with standard ANT+ devices. The "+" is essential: the non-plus SL model would work ONLY with Power Tap's own head unit. Make sure it's a "+" model.

The SL+ was a 2nd generation model. The current PT hubs are 3rd gen, and have better bearings than the G2. You can often find used G3 models pretty cheap--in January, a guy I know bought a used G3 hub mounted in a 28-spoke rim (okay but not great, and needed a little truing) with a still usable tire for $225. It was local so we were able to check it out to verify that it was working.
This leads me to believe that the item in question is not an SL+, because the seller says it won't work with a Garmin or Wahoo.
noodle soup is offline  
Old 06-10-20, 10:20 AM
  #7  
woodcraft
Senior Member
Thread Starter
 
woodcraft's Avatar
 
Join Date: Apr 2012
Location: Nor Cal
Posts: 6,016
Mentioned: 17 Post(s)
Tagged: 0 Thread(s)
Quoted: 1814 Post(s)
Likes: 0
Liked 919 Times in 567 Posts
Originally Posted by noodle soup View Post
This leads me to believe that the item in question is not an SL+, because the seller says it won't work with a Garmin or Wahoo.

This is the listing:

https://www.ebay.com/itm/HED-Stinger...YAAOSw~6BexECF
woodcraft is offline  
Old 06-10-20, 10:36 AM
  #8  
noodle soup
Senior Member
 
noodle soup's Avatar
 
Join Date: Nov 2015
Posts: 8,910
Mentioned: 20 Post(s)
Tagged: 0 Thread(s)
Quoted: 4694 Post(s)
Liked 1,860 Times in 991 Posts
Originally Posted by woodcraft View Post
Looks good to me, and I would trust RChung assessment. It should work with your Garmin.
noodle soup is offline  
Old 06-10-20, 10:41 AM
  #9  
Riveting
Senior Member
 
Join Date: Oct 2013
Location: Highlands Ranch, CO
Posts: 1,221

Bikes: '13 Diamondback Hybrid Commuter, '17 Spec Roubaix Di2, '17 Spec Camber 29'er, '19 CDale Topstone Gravel

Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 589 Post(s)
Liked 444 Times in 260 Posts
I've had a PowerTap G3 hub since 2015, and it now has about 16,000 miles on it. It's always been used in all types of weather and conditions. It connects to my Garmin 520 via BlueTooth flawlessly, as well as my previous Garmin 800, and it still gets about 1,500 miles per coin cell battery. Highly recommend.
Riveting is offline  
Old 07-30-21, 08:50 AM
  #10  
pjcampbell
fair weather cyclist
 
pjcampbell's Avatar
 
Join Date: Sep 2006
Location: Green Mountains
Posts: 1,368

Bikes: Colnago c50

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked 12 Times in 8 Posts
I know this is oooooooooooold but the SL+ had to be updated to support ANT+. If it was never updated, I believe you now no longer have the option to update it because the update tools are now all gone/off the market. Is this correct?
pjcampbell is offline  
Old 07-30-21, 09:07 AM
  #11  
himespau 
Senior Member
 
himespau's Avatar
 
Join Date: Jun 2008
Location: Louisville, KY
Posts: 13,052
Mentioned: 31 Post(s)
Tagged: 0 Thread(s)
Quoted: 3570 Post(s)
Liked 2,353 Times in 1,396 Posts
Originally Posted by pjcampbell View Post
I know this is oooooooooooold but the SL+ had to be updated to support ANT+. If it was never updated, I believe you now no longer have the option to update it because the update tools are now all gone/off the market. Is this correct?
the + in SL+ (or Pro+ or SLC+) specifically was for ANT+. The update was if you wanted Bluetooth (more recent update) or if you had an SL (or SLC or 2.4 or Pro) that you wanted to use ANT+ with (older update). I have an SL+ hub that wasn't updated that I used with my garmin 800, garmin 1000 and ANT+ antenna on Zwift for year (until I was hit by a car in May and it finally got killed).
himespau is offline  
Old 07-30-21, 09:15 AM
  #12  
pjcampbell
fair weather cyclist
 
pjcampbell's Avatar
 
Join Date: Sep 2006
Location: Green Mountains
Posts: 1,368

Bikes: Colnago c50

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked 12 Times in 8 Posts
Originally Posted by himespau View Post
the + in SL+ (or Pro+ or SLC+) specifically was for ANT+. The update was if you wanted Bluetooth (more recent update) or if you had an SL (or SLC or 2.4 or Pro) that you wanted to use ANT+ with (older update). I have an SL+ hub that wasn't updated that I used with my garmin 800, garmin 1000 and ANT+ antenna on Zwift for year (until I was hit by a car in May and it finally got killed).
Ahhh ok thanks. I doubled checked and what I have are "2.4" , pretty old stuff. I remember when the ant+ upgrade dongle was available, and I never jumped on it. Do I have any options? I still have the old yellow bike computers (wireless) but not actually sure the newer PowerAgent software will download anything off of them. I'm trying now. I've been on a (very) long hiatus from cycling!!!
pjcampbell is offline  
Old 07-30-21, 09:25 AM
  #13  
himespau 
Senior Member
 
himespau's Avatar
 
Join Date: Jun 2008
Location: Louisville, KY
Posts: 13,052
Mentioned: 31 Post(s)
Tagged: 0 Thread(s)
Quoted: 3570 Post(s)
Liked 2,353 Times in 1,396 Posts
I don't think you have any options at this point other than using the yellow computer or finding a "+" hub and swapping it in your wheel. I ended up deciding to make the expensive switch to pedal-based when I saw that I have few options now with my broken hub and will have fewer and fewer options as time goes buy if I bought a new one and it failed down the road. Expensive bummer because it means 2 purchases - new wheel AND new powermeter. You, at least, can continue to ride your powertap wheel as a regular wheel if you want to buy a new ANT+ or bluetooth compatible powermeter. Or you could go with a used powertap wheel - that's still the cheapest way to get into power.
himespau is offline  
Old 07-30-21, 09:45 AM
  #14  
Andy Somnifac 
Shut up legs.
 
Andy Somnifac's Avatar
 
Join Date: Aug 2009
Posts: 1,297

Bikes: Too many.

Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 92 Post(s)
Liked 173 Times in 86 Posts
I use an SL+ hub with both Garmin and Wahoo computers 5 days a week. It works fine.
__________________


Andy Somnifac is offline  
Old 03-24-22, 05:14 AM
  #15  
uffa
Newbie
 
Join Date: Mar 2022
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 1 Time in 1 Post
Yellow CPU not detecting hub

Originally Posted by Andy Somnifac View Post
I use an SL+ hub with both Garmin and Wahoo computers 5 days a week. It works fine.
Hi!
I'm getting crazy... My Garmin Edge can detect the hub but my yellow powertap head unit cannot... It is a wireless version, it searches for the hub and cannot find.... Any hint?
uffa is offline  
Old 03-24-22, 05:29 AM
  #16  
chaadster
Thread Killer
 
Join Date: Aug 2008
Location: Ann Arbor, MI
Posts: 11,680

Bikes: '15 Kinesis Racelight 4S, '76 Motebecane Gran Jubilée, '17 Dedacciai Gladiatore2, '12 Breezer Venturi, '09 Dahon Mariner, '12 Mercier Nano, '95 DeKerf Team SL, '19 Tern Rally, ‘21 Breezer Doppler Cafe+, ‘19 T-Lab X3

Mentioned: 25 Post(s)
Tagged: 0 Thread(s)
Quoted: 2178 Post(s)
Liked 1,215 Times in 745 Posts
Originally Posted by uffa View Post
Hi!
I'm getting crazy... My Garmin Edge can detect the hub but my yellow powertap head unit cannot... It is a wireless version, it searches for the hub and cannot find.... Any hint?
It has been awhile so I’m not sure if it was all Powertap Cervo— the yellow computer head unit— but certainly most Cervos were not ANT+ compatible, as Powertap had their own comm protocol. I think ANT+ came to Powertap head units with the Joule, the grayish-brown unit with yellow button pad. You’ve obviously got an ANT+ Powertap hub if Edge sees it, so it’s just that your Cervo is incompatible.
chaadster is offline  
Old 03-24-22, 06:20 AM
  #17  
himespau 
Senior Member
 
himespau's Avatar
 
Join Date: Jun 2008
Location: Louisville, KY
Posts: 13,052
Mentioned: 31 Post(s)
Tagged: 0 Thread(s)
Quoted: 3570 Post(s)
Liked 2,353 Times in 1,396 Posts
I think there were a few of the yellow ones a the very end of the run that could detect Ant+ (could be wrong, it might be that they were just mislabeled by the sellers or I misread the advertisements), but almost all of them could only detect the wireless hubs labeled 2.4 or Comp, Pro, SL, or SLC without the + after it.
himespau is offline  
Likes For himespau:
Old 03-25-22, 06:04 AM
  #18  
uffa
Newbie
 
Join Date: Mar 2022
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 1 Time in 1 Post
I think it should be compatible - it should communicate using Powertap protocol instead of ANT+.. The hub is SL+ while the yellow unit does not have the "WIRED" stamp on its side and it clearly searches for something, its version is 6. I found something about "Learn" in setup menu #5, I'lll try this. I tried to manually enter the device id but in vain..
uffa is offline  
Old 03-25-22, 09:35 AM
  #19  
chaadster
Thread Killer
 
Join Date: Aug 2008
Location: Ann Arbor, MI
Posts: 11,680

Bikes: '15 Kinesis Racelight 4S, '76 Motebecane Gran Jubilée, '17 Dedacciai Gladiatore2, '12 Breezer Venturi, '09 Dahon Mariner, '12 Mercier Nano, '95 DeKerf Team SL, '19 Tern Rally, ‘21 Breezer Doppler Cafe+, ‘19 T-Lab X3

Mentioned: 25 Post(s)
Tagged: 0 Thread(s)
Quoted: 2178 Post(s)
Liked 1,215 Times in 745 Posts
Originally Posted by uffa View Post
I think it should be compatible - it should communicate using Powertap protocol instead of ANT+..
Only if the SL+ is old enough to still have the original Powertap comm protocol. I’m sure the SL+ model continued into the Powertap ANT+ only era; the PT/ANT+ Sport period, where both were on board the SL+, was quite short as I recall.

Anyway, good luck.
chaadster is offline  
Old 03-28-22, 07:55 AM
  #20  
uffa
Newbie
 
Join Date: Mar 2022
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Likes: 0
Liked 1 Time in 1 Post
Hi! I solved it! In Setup Section #5 of the yellow unit there is the "Learn" function. It is used to detect new hubs and other new peripherals, I mean: the unit stores the ID of peripherals and, if you use a new hub, its ID does not match the stored ID and the "autodetect" at start may not find it. With the "Learn" function the new ID is detected and stored. Or, at least, this is what I understood. Anyway, it worked :-)
The SL+ hub
Thanks for your interest and advicing :-)
uffa is offline  
Likes For uffa:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.