Go Back  Bike Forums > Bike Forums > Bicycle Mechanics
Reload this Page >

BB386EVO with BSA Bearing Cups Creaking Issue

Bicycle Mechanics Broken bottom bracket? Tacoed wheel? If you're having problems with your bicycle, or just need help fixing a flat, drop in here for the latest on bicycle mechanics & bicycle maintenance.

BB386EVO with BSA Bearing Cups Creaking Issue

Old 10-15-16, 08:03 PM
  #1  
jdutko
Newbie
Thread Starter
 
Join Date: Sep 2016
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
BB386EVO with BSA Bearing Cups Creaking Issue

Hi All,

I recently installed the FSA MegaEvo bottom bracket and FSA SL-K Light EVO386 cranks. The crank/bb is creaking and I am surprised and looking for suggestions on how to fix it.

The bb cups screwed in perfectly well. I greased all the threads and the spindle. The spindle was tight going through the drive side (I had to use a rubber mallet) but it went all the way in. I greased fixing bolt and tightened the left crank arm to spec and everything spun well. After about four rides I now have constant creaking under load, e.g., going uphill. I am surprised because this is not a press fit frame, it is BSA english thread.

Could the creaking be coming from the contact between the spindle and bearing race (which I greased)? Or could it be from the bearings themselves maybe because the spindle might not be centered to the frame?

A related question, are the cranks automatically centered relative to the frame and BB in these friction systems? To properly install does one simply push the spindle all the way in to touch the bearing dust cap or should there be some spindle showing on the drive side?

Thanks,

James
jdutko is offline  
Old 08-04-17, 03:00 PM
  #2  
SHH
Newbie
 
Join Date: Aug 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
me too

I had hoped to see some brilliant suggestion.
But I can verify that it's happened to someone else.
Frame: Lynskey CX cross/ titanium/ threaded BB shell
BB: FSA EVO 386
Crank: FSA Gossamer CX 46-36

Installed per instructions.
Worked perfectly for 2 months. Not a sound.
Then creaking. Under light and heavy load. Timed to revolutions of the crank.
(Does not creak if just one pedal is used. Not enough force? More meaningful?

I re-torqued the crank to 41NM/ no fix
I removed crank and regreased and retorqued. Nope.
I removed the BB cups and rertorqued. Nope.
The creaking did not even change.

Not the crank or bb??
I greased the handlebar/ stem junction ... seat rails ... seatpost cradle... I changed pedals
Nope.

creak creak creak
F##K
SHH is offline  
Old 05-17-18, 01:59 PM
  #3  
jeza64
Newbie
 
Join Date: May 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Likes: 0
Liked 0 Times in 0 Posts
i know its been a while but did you find a solution ??? i have fsa sl-k light bb386 evo with power2max power meter. sent it back to them and they assure me there is no problem but a year or so on and i'm still getting a creak/click[ not as bad as before ] on each pedal stroke not under much load !!!
jeza64 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.