Electric Bikes Here's a place to discuss ebikes, from home grown to high-tech.

Throttle help

Reply

Old 12-17-15, 09:35 AM
  #1  
Courier84
Newbie
Thread Starter
 
Join Date: Dec 2015
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Throttle help

Hi. New to the Ebike world. When I'm on my ebike my throttle doesn't work. When off the Ebike it work. Any idea why? Any way of fixing this? Thanks
Courier84 is offline  
Reply With Quote
Old 12-17-15, 10:24 AM
  #2  
corrado33
Senior Member
 
Join Date: Jun 2013
Location: Bozeman
Posts: 4,135

Bikes: 199? Landshark Roadshark, 198? Mondonico Diamond, 1987 Panasonic DX-5000, 1987 Bianchi Limited, Univega... Chrome..., 1989 Schwinn Woodlands, Motobecane USA Record, Raleigh Tokul 2

Mentioned: 24 Post(s)
Tagged: 0 Thread(s)
Quoted: 1119 Post(s)
Originally Posted by Courier84 View Post
Hi. New to the Ebike world. When I'm on my ebike my throttle doesn't work. When off the Ebike it work. Any idea why? Any way of fixing this? Thanks
Dead battery? Not enough juice to get you started from a stop? Have you tried using it while pedaling the bike at speed?

What bike is it?
corrado33 is offline  
Reply With Quote
Old 12-17-15, 11:06 AM
  #3  
bobbrooke
Junior Member
 
Join Date: Jun 2015
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sounds like not enough in the battery
bobbrooke is offline  
Reply With Quote
Old 12-17-15, 11:15 AM
  #4  
Courier84
Newbie
Thread Starter
 
Join Date: Dec 2015
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I own 2 batterys. The Ebike I have is X-Treme Trail Maker Lithium Electric Mountain Bicycle, Black.
Courier84 is offline  
Reply With Quote
Old 12-17-15, 11:21 AM
  #5  
Courier84
Newbie
Thread Starter
 
Join Date: Dec 2015
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
PAS work perfectly fine. TAG is the problem.
Courier84 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service